summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2018-05-02 18:58:43 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2018-05-02 20:17:10 +0300
commitb836c6500a7bdc81c6dcfcb27aa61d347bb5ad74 (patch)
tree8f719e2721c0d9985976f99f079bd292c25a83de
parentbe3cf803da25efcc6a943e6a4a693bcd6dced2eb (diff)
downloadpatches-b836c6500a7bdc81c6dcfcb27aa61d347bb5ad74.tar
patches-b836c6500a7bdc81c6dcfcb27aa61d347bb5ad74.tar.gz
gnu: Add emacs-loop.
* gnu/packages/emacs.scm (emacs-loop): New public variable.
-rw-r--r--gnu/packages/emacs.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 77f003c20e..a4163f8eb6 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -8613,3 +8613,24 @@ that allows you to filter the tail with unix pipes and highlight the
contents of the tailed file. Works locally or on remote files using
tramp.")
(license license:gpl3+))))
+
+(define-public emacs-loop
+ (package
+ (name "emacs-loop")
+ (version "1.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/Wilfred/loop.el/archive/"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1z3rhh3zyjabz36410yz0lp4a0qwwj0387as662wvx3z9y54jia9"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/Wilfred/loop.el")
+ (synopsis "Imperative loop structures for Emacs")
+ (description "Loop structures familiar to users of other languages. This
+library adds a selection of popular loop structures as well as break and
+continue.")
+ (license license:gpl3+)))