summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2018-05-02 18:51:16 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2018-05-02 20:17:07 +0300
commita34d562a59a3c1f0b535fbf0f8cbcc5d0c70ec77 (patch)
tree9af56155ad6c34317e3da86a97d12d5285bb4965
parent63e6c4ad99bb2ddcd40d79d003775dde98d19bc6 (diff)
downloadpatches-a34d562a59a3c1f0b535fbf0f8cbcc5d0c70ec77.tar
patches-a34d562a59a3c1f0b535fbf0f8cbcc5d0c70ec77.tar.gz
gnu: Add emacs-outorg.
* gnu/packages/emacs.scm (emacs-outorg): New public variable.
-rw-r--r--gnu/packages/emacs.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 440ff18abf..af9e4a8e76 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -8111,3 +8111,28 @@ newsreader.")
(description
"This package provides an Emacs interactive command-line mode.")
(license license:gpl3+)))
+
+(define-public emacs-outorg
+ (let ((commit "78b0695121fb974bc4e971eb4ef7f8afd6d89d64"))
+ (package
+ (name "emacs-outorg")
+ (version (git-version "2.0" "1" commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/alphapapa/outorg")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "03aclh4m3f7rb821gr9pwvnqkkl91px3qxdcarpf3ypa1x4fxvlj"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/alphapapa/outorg")
+ (synopsis "Org-style comment editing")
+ (description "Outorg is for editing comment-sections of source-code
+files in temporary Org-mode buffers. It turns conventional
+literate-programming upside-down in that the default mode is the
+programming-mode, and special action has to be taken to switch to the
+text-mode (i.e. Org-mode).")
+ (license license:gpl3+))))