summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2018-05-02 19:00:46 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2018-05-02 20:17:10 +0300
commit15d568330bdd10694b358ff0d5de909ced7f7cdd (patch)
treee577a9d40ae8bf2e7ec003e23e6b8d05cf5c823f
parent4024607561d04899769a9ee98b1d23d1c2c3aef1 (diff)
downloadpatches-15d568330bdd10694b358ff0d5de909ced7f7cdd.tar
patches-15d568330bdd10694b358ff0d5de909ced7f7cdd.tar.gz
gnu: Add emacs-let-alist.
* gnu/packages/emacs.scm (emacs-let-alist): New public variable.
-rw-r--r--gnu/packages/emacs.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 60daf19948..9370f4b93a 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -8741,3 +8741,22 @@ confused by comments or @code{foo-bar} matching @code{foo}.")
(description "@code{m-buffer} provides a set of list-orientated functions
for operating over the contents of Emacs buffers.")
(license license:gpl3+)))
+
+(define-public emacs-let-alist
+ (package
+ (name "emacs-let-alist")
+ (version "1.0.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://elpa.gnu.org/packages/let-alist-" version ".el"))
+ (sha256
+ (base32
+ "0r7b9jni50la1m79kklml11syg8d2fmdlr83pv005sv1wh02jszw"))))
+ (build-system emacs-build-system)
+ (home-page "https://elpa.gnu.org/packages/let-alist.html")
+ (synopsis "Easily let-bind values of an assoc-list by their names")
+ (description "This package offers a single macro, @code{let-alist}. This
+macro takes a first argument (whose value must be an alist) and a body.")
+ (license license:gpl3+)))