summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2020-04-14 15:05:18 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2020-04-14 15:09:20 +0200
commitdf95189db60ea1056ea1ca67ac789ec2b74e2bc3 (patch)
treef42928c8a0be203da68e736e28496f8f2a86f6b2
parent45c54093d5d861fb2a34d45b922408e36fd49405 (diff)
downloadpatches-df95189db60ea1056ea1ca67ac789ec2b74e2bc3.tar
patches-df95189db60ea1056ea1ca67ac789ec2b74e2bc3.tar.gz
gnu: Add cl-change-case.
* gnu/packages/lisp-xyz.scm (cl-change-case, sbcl-cl-change-case): New variables.
-rw-r--r--gnu/packages/lisp-xyz.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 795ff66f8d..5c29d59014 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -11352,3 +11352,38 @@ multiple checkers, including Aspell and Hunspell.")
(define-public cl-enchant
(sbcl-package->cl-source-package sbcl-enchant))
+
+(define-public sbcl-cl-change-case
+ (let ((commit "5ceff2a5f8bd845b6cb510c6364176b27a238fd3"))
+ (package
+ (name "sbcl-cl-change-case")
+ (version (git-version "0.1.0" "1" commit))
+ (home-page "https://github.com/rudolfochrist/cl-change-case")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1afyglglk9z3yg8gylcl301bl2r8vq3sllyznzj9s5xi5gs6qyf2"))))
+ (build-system asdf-build-system/sbcl)
+ (inputs
+ `(("cl-ppcre" ,sbcl-cl-ppcre)
+ ("cl-ppcre-unicode" ,sbcl-cl-ppcre-unicode)))
+ (native-inputs
+ `(("fiveam" ,sbcl-fiveam)))
+ (arguments
+ '(;; FIXME: Test pass but phase fails with 'Component
+ ;; "cl-change-case-test" not found, required by'.
+ #:tests? #f
+ #:test-asd-file "cl-change-case-test.asd"))
+ (synopsis "Convert Common Lisp strings between camelCase, PascalCase and more")
+ (description
+ "@code{cl-change-case} is library to convert strings between camelCase,
+PascalCase, snake_case, param-case, CONSTANT_CASE and more.")
+ (license license:llgpl))))
+
+(define-public cl-change-case
+ (sbcl-package->cl-source-package sbcl-cl-change-case))