summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathieu Lirzin <mthl@gnu.org>2016-04-18 21:36:42 +0200
committerMathieu Lirzin <mthl@gnu.org>2016-04-21 17:49:10 +0200
commitdc9bdb1e2730589ff7c2ec5f1e601f4262eac9d6 (patch)
tree03b1019269714e0ab4443d9797dfd5f2dcd351d1
parent85fc958d9b8b36fb4b540882dfbcec45aab9eb82 (diff)
downloadpatches-dc9bdb1e2730589ff7c2ec5f1e601f4262eac9d6.tar
patches-dc9bdb1e2730589ff7c2ec5f1e601f4262eac9d6.tar.gz
gnu: Add acpi.
* gnu/packages/linux.scm (acpi): New variable.
-rw-r--r--gnu/packages/linux.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index d554ecc17a..fbbefbec1d 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -10,6 +10,7 @@
;;; Copyright © 2016 Tobias Geerinckx-Rice <tobias.geerinckx.rice@gmail.com>
;;; Copyright © 2016 Alex Kost <alezost@gmail.com>
;;; Copyright © 2016 Raymond Nicholson <rain1@openmailbox.org>
+;;; Copyright © 2016 Mathieu Lirzin <mthl@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2104,6 +2105,26 @@ WLAN, Bluetooth and mobile broadband.")
(license (license:non-copyleft "file://COPYING"
"See COPYING in the distribution."))))
+(define-public acpi
+ (package
+ (name "acpi")
+ (version "1.7")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/acpiclient/"
+ name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "01ahldvf0gc29dmbd5zi4rrnrw2i1ajnf30sx2vyaski3jv099fp"))))
+ (build-system gnu-build-system)
+ (home-page "http://acpiclient.sourceforge.net")
+ (synopsis "Display information on ACPI devices")
+ (description "@code{acpi} attempts to replicate the functionality of the
+\"old\" @code{apm} command on ACPI systems, including battery and thermal
+information. It does not support ACPI suspending, only displays information
+about ACPI devices.")
+ (license license:gpl2+)))
+
(define-public acpid
(package
(name "acpid")