summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Garlick <pgarlick@tourbillion-technology.com>2020-04-09 18:11:46 +0100
committerPaul Garlick <pgarlick@tourbillion-technology.com>2020-04-14 14:41:36 +0100
commitca6b80c7f98dd9a4724f307fa256d72efebc6143 (patch)
tree8ba5acd6dbf701fcbc29cd04ea457abb0192cf11
parent5b660f9f3214060a07de79a8e590ede29c9bdc64 (diff)
downloadpatches-ca6b80c7f98dd9a4724f307fa256d72efebc6143.tar
patches-ca6b80c7f98dd9a4724f307fa256d72efebc6143.tar.gz
gnu: Add perl-crypt-mysql.
* gnu/packages/perl.scm (perl-crypt-mysql): New variable.
-rw-r--r--gnu/packages/perl.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 7207e68996..a7117af672 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -52,6 +52,7 @@
#:use-module (guix build-system perl)
#:use-module (gnu packages base)
#:use-module (gnu packages compression)
+ #:use-module (gnu packages databases)
#:use-module (gnu packages freedesktop)
#:use-module (gnu packages gd)
#:use-module (gnu packages less)
@@ -1892,6 +1893,33 @@ also includes an implementation of @code{bcrypt}, the Unix crypt()
password hashing algorithm based on Eksblowfish.")
(license perl-license)))
+(define-public perl-crypt-mysql
+ (package
+ (name "perl-crypt-mysql")
+ (version "0.04")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/I/IK/IKEBE/Crypt-MySQL-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1qyx6ha13r0rh80ldv5wy2bq2pa74igwh8817xlapsfgxymdzswk"))))
+ (build-system perl-build-system)
+ (native-inputs
+ `(("perl-module-build" ,perl-module-build)
+ ("perl-dbd-mysql" ,perl-dbd-mysql)))
+ (propagated-inputs
+ `(("perl-digest-sha1" ,perl-digest-sha1)))
+ (home-page "https://metacpan.org/release/Crypt-MySQL")
+ (synopsis "Emulate the MySQL PASSWORD() function")
+ (description "@code{Crypt::MySQL} emulates the MySQL PASSWORD()
+function. The module does not depend on an interface to the MySQL
+database server. This enables the comparison of encrypted passwords
+without the need for a real MySQL environment.")
+ (license perl-license)))
+
(define-public perl-crypt-passwdmd5
(package
(name "perl-crypt-passwdmd5")