summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Garlick <pgarlick@tourbillion-technology.com>2020-04-14 12:53:02 +0100
committerPaul Garlick <pgarlick@tourbillion-technology.com>2020-04-14 14:41:39 +0100
commit602fc1e5fa90241d515c7f509d0540ffbe14330f (patch)
treeeb280038a697d06b8f8c7739e3d2cad363a7a956
parent77cf8b2c60438355e1891c824c763d63da5782f1 (diff)
downloadpatches-602fc1e5fa90241d515c7f509d0540ffbe14330f.tar
patches-602fc1e5fa90241d515c7f509d0540ffbe14330f.tar.gz
gnu: Add perl-digest-md4.
* gnu/packages/perl.scm (perl-digest-md4): New variable.
-rw-r--r--gnu/packages/perl.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index dccc07d466..b48574117c 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -3546,6 +3546,29 @@ for CRC-CCITT, CRC-16 and CRC-32.")
interface for the RFC 2104 HMAC mechanism.")
(license (package-license perl))))
+(define-public perl-digest-md4
+ (package
+ (name "perl-digest-md4")
+ (version "1.9")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/M/MI/MIKEM/DigestMD4/Digest-MD4-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "19ma1hmvgiznq95ngzvm6v4dfxc9zmi69k8iyfcg6w14lfxi0lb6"))))
+ (build-system perl-build-system)
+ (home-page "https://metacpan.org/release/Digest-MD4")
+ (synopsis "Interface to the MD4 Algorithm")
+ (description "The @code{Digest::MD4} module allows you to use the
+RSA Data Security Inc.@: MD4 Message Digest algorithm from within Perl
+programs. The algorithm takes as input a message of arbitrary length
+and produces as output a 128-bit \"fingerprint\" or \"message digest\"
+of the input. MD4 is described in RFC 1320.")
+ (license perl-license)))
+
(define-public perl-digest-md5
(package
(name "perl-digest-md5")