summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Garlick <pgarlick@tourbillion-technology.com>2020-04-10 00:39:29 +0100
committerPaul Garlick <pgarlick@tourbillion-technology.com>2020-04-14 14:41:37 +0100
commit2aa17cef570061c1b0d0b44f3de092e8f2ecdf1e (patch)
treeefe7fd211053f042e2ce4996b69160a6b971f326
parentca6b80c7f98dd9a4724f307fa256d72efebc6143 (diff)
downloadpatches-2aa17cef570061c1b0d0b44f3de092e8f2ecdf1e.tar
patches-2aa17cef570061c1b0d0b44f3de092e8f2ecdf1e.tar.gz
gnu: Add perl-crypt-cbc.
* gnu/packages/perl.scm (perl-crypt-cbc): New variable.
-rw-r--r--gnu/packages/perl.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index a7117af672..e501391d97 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -1859,6 +1859,31 @@ CPAN::Meta object are present.")
versa.")
(license (package-license perl))))
+(define-public perl-crypt-cbc
+ (package
+ (name "perl-crypt-cbc")
+ (version "2.33")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/L/LD/LDS/Crypt-CBC-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0ig698lmpjz7fslnznxm0609lvlnvf4f3s370082nzycnqhxww3a"))))
+ (build-system perl-build-system)
+ (native-inputs
+ `(("perl-crypt-rijndael" ,perl-crypt-rijndael)))
+ (home-page "https://metacpan.org/release/Crypt-CBC")
+ (synopsis "Encrypt Data with Cipher Block Chaining Mode")
+ (description "@code{Crypt::CBC} is a Perl-only implementation of
+the cryptographic Cipher Block Chaining (CBC) mode. In combination
+with a block cipher such as @code{Crypt::Rijndael} you can encrypt and
+decrypt messages of arbitrarily long length. The encrypted messages
+are compatible with the encryption format used by SSLeay.")
+ (license perl-license)))
+
(define-public perl-crypt-eksblowfish
(package
(name "perl-crypt-eksblowfish")