summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-04-14 10:24:25 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-04-14 10:25:28 +0300
commit01a2911e3611efd078387a86bf60114316bc35b4 (patch)
tree14f95636827f6addf1d28e83bfc0551be6ce8c67
parentc206b8398541d052d506c57f627c5c3c7d26686b (diff)
downloadpatches-01a2911e3611efd078387a86bf60114316bc35b4.tar
patches-01a2911e3611efd078387a86bf60114316bc35b4.tar.gz
gnu: volk: Update to 2.2.1.
* gnu/packages/engineering.scm (volk): Update to 2.2.1. [source]: Download using https. [arguments]: Add phase to wrap binary in PYTHONPATH. [native-inputs]: Remove python-2, python2-cheetah. Add python-wrapper, python-mako. [home-page]: Use https.
-rw-r--r--gnu/packages/engineering.scm32
1 files changed, 26 insertions, 6 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 5405db762c..ac50efb923 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -1017,22 +1017,42 @@ the 'showing the effect of'-style of operation.")
(define-public volk
(package
(name "volk")
- (version "1.3")
+ (version "2.2.1")
(source
(origin
(method url-fetch)
- (uri (string-append "http://libvolk.org/releases/volk-"
+ (uri (string-append "https://www.libvolk.org/releases/volk-"
version ".tar.gz"))
(sha256
(base32
- "1bz3ywc6y5wmz3i8p4z2wbzhns8bc0ywdkl9qnxpcvfcscarbdlh"))))
+ "1wz5nhmw6np8ka30pgy1qnima3rk2ksln4klfhrj7wah3fian0k9"))))
(build-system cmake-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'wrap-pythonpath
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (python (assoc-ref inputs "python"))
+ (file (string-append out "/bin/volk_modtool"))
+ (path (string-append
+ out
+ "/lib/python"
+ ,(version-major+minor
+ (package-version python))
+ "/site-packages:"
+ (getenv "PYTHONPATH"))))
+ (wrap-program file
+ `("PYTHONPATH" ":" prefix (,path))
+ `("PATH" ":" prefix
+ (,(string-append python "/bin:")))))
+ #t)))))
(inputs
`(("boost" ,boost)))
(native-inputs
- `(("python-2" ,python-2)
- ("python2-cheetah" ,python2-cheetah)))
- (home-page "http://libvolk.org/")
+ `(("python" ,python-wrapper)
+ ("python-mako" ,python-mako)))
+ (home-page "https://www.libvolk.org/")
(synopsis "Vector-Optimized Library of Kernels")
(description
"@code{volk} contains procedures with machine-specific optimizations