summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan (janneke) Nieuwenhuizen <janneke@gnu.org>2020-04-14 16:20:52 +0200
committerJan Nieuwenhuizen <janneke@gnu.org>2020-04-14 16:21:36 +0200
commit22a98cda38784107a1d1c9cd7afc0c80944a9027 (patch)
tree05e9b6930116d291cde0cf6f4cbe7f3a9f2e1f2d
parent53c05faf18b30f3d5746878bc52c7b7c46d43352 (diff)
downloadpatches-22a98cda38784107a1d1c9cd7afc0c80944a9027.tar
patches-22a98cda38784107a1d1c9cd7afc0c80944a9027.tar.gz
gnu: Add rkdeveloptool.
* gnu/packages/hardware.scm (rkdeveloptool): New variable.
-rw-r--r--gnu/packages/hardware.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/hardware.scm b/gnu/packages/hardware.scm
index 4c9c45bc48..53dad58e3f 100644
--- a/gnu/packages/hardware.scm
+++ b/gnu/packages/hardware.scm
@@ -17,6 +17,7 @@
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(define-module (gnu packages hardware)
+ #:use-module (gnu packages autotools)
#:use-module (gnu packages compression)
#:use-module (gnu packages gcc)
#:use-module (gnu packages glib)
@@ -276,3 +277,32 @@ supported by the Linux kernel.")
;; Source file headers still say GPL2+, but the authorial intent
;; (from COPYING and the F9 'about' screen) is clearly GPL3+.
(license license:gpl3+)))
+
+(define-public rkdeveloptool
+ (let ((commit "6e92ebcf8b1812da02663494a68972f956e490d3")
+ (revision "0"))
+ (package
+ (name "rkdeveloptool")
+ (version (git-version "1.3" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/rockchip-linux/rkdeveloptool.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0zwrkqfxd671iy69v3q0844gfdpm1yk51i9qh2rqc969bd8glxga"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("libusb" ,libusb)))
+ (home-page "https://github.com/rockchip-linux/rkdeveloptool")
+ (synopsis "Read from and write to RockChicp devices over USB")
+ (description
+ "Rkdeveloptool can read from and write to RockChip devices over USB, such
+as the Pinebook Pro.")
+ (license license:gpl2+))))