summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2019-07-16 17:00:08 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-07-16 17:03:19 +0200
commit34c2a16b107362dae35dfb722547639365198e24 (patch)
tree76066e6b85eaf58f22d03f605bc7d0949a83111a
parent84d7784afe00dfc23c7feeb7ede6bce73406760b (diff)
downloadpatches-34c2a16b107362dae35dfb722547639365198e24.tar
patches-34c2a16b107362dae35dfb722547639365198e24.tar.gz
gnu: python-matplotlib: Do not propagate GTK+ or python-pyqt.
* gnu/packages/python-xyz.scm (python-matplotlib)[propagated-inputs]: Remove gtk+ and python-pyqt. [arguments]: Adjust configure-environment phase.
-rw-r--r--gnu/packages/python-xyz.scm19
1 files changed, 3 insertions, 16 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index eda21d8c64..e65b6a1fa8 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -3809,22 +3809,11 @@ convert between colorspaces like sRGB, XYZ, CIEL*a*b*, CIECAM02, CAM02-UCS, etc.
("python-pillow" ,python-pillow)
("python-pytz" ,python-pytz)
("python-six" ,python-six)
- ;; The 'gtk+' package (and 'gdk-pixbuf', 'atk' and 'pango' propagated
- ;; from 'gtk+') provides the required 'typelib' files used by
- ;; 'gobject-introspection'. The location of these files is set with the
- ;; help of the environment variable GI_TYPELIB_PATH. At build time this
- ;; is done automatically by a 'native-search-path' procedure. However,
- ;; at run-time the user must set this variable as follows:
- ;;
- ;; export GI_TYPELIB_PATH=~/.guix-profile/lib/girepository-1.0
- ("gtk+" ,gtk+)
;; From version 1.4.0 'matplotlib' makes use of 'cairocffi' instead of
;; 'pycairo'. However, 'pygobject' makes use of a 'pycairo' 'context'
;; object. For this reason we need to import both libraries.
;; https://pythonhosted.org/cairocffi/cffi_api.html#converting-pycairo
("python-pycairo" ,python-pycairo)
- ;; XXX: qtwebkit cannot be built reliably.
- ("python-pyqt" ,python-pyqt-without-qtwebkit)
("python-cairocffi" ,python-cairocffi)))
(inputs
`(("libpng" ,libpng)
@@ -3845,12 +3834,10 @@ convert between colorspaces like sRGB, XYZ, CIEL*a*b*, CIECAM02, CAM02-UCS, etc.
(modify-phases %standard-phases
(add-before 'build 'configure-environment
(lambda* (#:key outputs inputs #:allow-other-keys)
- (let ((cairo (assoc-ref inputs "cairo"))
- (gtk+ (assoc-ref inputs "gtk+")))
- ;; Setting these directories in the 'basedirlist' of 'setup.cfg'
+ (let ((cairo (assoc-ref inputs "cairo")))
+ ;; Setting this directory in the 'basedirlist' of 'setup.cfg'
;; has not effect.
- (setenv "LD_LIBRARY_PATH"
- (string-append cairo "/lib:" gtk+ "/lib"))
+ (setenv "LD_LIBRARY_PATH" (string-append cairo "/lib"))
(setenv "HOME" (getcwd))
(call-with-output-file "setup.cfg"
(lambda (port)