summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-06-10 10:58:30 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-06-10 13:41:45 +0200
commita9fac3f4d3e8fb579314afc6d22add1394f2fe7f (patch)
treeceafd0d502f492388fcf679de1c853a2437c70ee
parent4252dace19945f56192477e8cb07973c20a526ba (diff)
downloadpatches-a9fac3f4d3e8fb579314afc6d22add1394f2fe7f.tar
patches-a9fac3f4d3e8fb579314afc6d22add1394f2fe7f.tar.gz
gnu: Add r-ropls.
* gnu/packages/bioconductor.scm (r-ropls): New variable.
-rw-r--r--gnu/packages/bioconductor.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index c1bbcdc2c0..f8bcb8eb4c 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -4606,3 +4606,39 @@ expression data to predict switches in regulatory activity between two
conditions. A Bayesian network is used to model the regulatory structure and
Markov-Chain-Monte-Carlo is applied to sample the activity states.")
(license license:gpl2+)))
+
+(define-public r-ropls
+ (package
+ (name "r-ropls")
+ (version "1.16.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "ropls" version))
+ (sha256
+ (base32
+ "099nv9dgmw3avkxv7cd27r16yj56svjlp5q4i389yp1n0r5zhyl2"))))
+ (build-system r-build-system)
+ (propagated-inputs `(("r-biobase" ,r-biobase)))
+ (native-inputs
+ `(("r-knitr" ,r-knitr))) ; for vignettes
+ (home-page "https://dx.doi.org/10.1021/acs.jproteome.5b00354")
+ (synopsis "Multivariate analysis and feature selection of omics data")
+ (description
+ "Latent variable modeling with @dfn{Principal Component Analysis} (PCA)
+and @dfn{Partial Least Squares} (PLS) are powerful methods for visualization,
+regression, classification, and feature selection of omics data where the
+number of variables exceeds the number of samples and with multicollinearity
+among variables. @dfn{Orthogonal Partial Least Squares} (OPLS) enables to
+separately model the variation correlated (predictive) to the factor of
+interest and the uncorrelated (orthogonal) variation. While performing
+similarly to PLS, OPLS facilitates interpretation.
+
+This package provides imlementations of PCA, PLS, and OPLS for multivariate
+analysis and feature selection of omics data. In addition to scores, loadings
+and weights plots, the package provides metrics and graphics to determine the
+optimal number of components (e.g. with the R2 and Q2 coefficients), check the
+validity of the model by permutation testing, detect outliers, and perform
+feature selection (e.g. with Variable Importance in Projection or regression
+coefficients).")
+ (license license:cecill)))