summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-06-10 10:58:39 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-06-10 13:41:48 +0200
commit075a90946b93eefeb30996978dd293147aaeff94 (patch)
treec3b9afef2b0583130369fd1890c1e9ad633cb42f
parenta9fac3f4d3e8fb579314afc6d22add1394f2fe7f (diff)
downloadpatches-075a90946b93eefeb30996978dd293147aaeff94.tar
patches-075a90946b93eefeb30996978dd293147aaeff94.tar.gz
gnu: Add r-biosigner.
* gnu/packages/bioconductor.scm (r-biosigner): New variable.
-rw-r--r--gnu/packages/bioconductor.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index f8bcb8eb4c..ff159638b3 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -4642,3 +4642,38 @@ validity of the model by permutation testing, detect outliers, and perform
feature selection (e.g. with Variable Importance in Projection or regression
coefficients).")
(license license:cecill)))
+
+(define-public r-biosigner
+ (package
+ (name "r-biosigner")
+ (version "1.12.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "biosigner" version))
+ (sha256
+ (base32
+ "1643iya40v6whb7lw7y34w5sanbasvj4yhvcygbip667yhphyv5b"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-biobase" ,r-biobase)
+ ("r-e1071" ,r-e1071)
+ ("r-randomforest" ,r-randomforest)
+ ("r-ropls" ,r-ropls)))
+ (native-inputs
+ `(("r-knitr" ,r-knitr)
+ ("r-rmarkdown" ,r-rmarkdown)
+ ("pandoc" ,ghc-pandoc)
+ ("pandoc-citeproc" ,ghc-pandoc-citeproc))) ; all for vignettes
+ (home-page "https://bioconductor.org/packages/biosigner/")
+ (synopsis "Signature discovery from omics data")
+ (description
+ "Feature selection is critical in omics data analysis to extract
+restricted and meaningful molecular signatures from complex and high-dimension
+data, and to build robust classifiers. This package implements a method to
+assess the relevance of the variables for the prediction performances of the
+classifier. The approach can be run in parallel with the PLS-DA, Random
+Forest, and SVM binary classifiers. The signatures and the corresponding
+'restricted' models are returned, enabling future predictions on new
+datasets.")
+ (license license:cecill)))