summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2020-04-12 15:05:35 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-04-12 15:22:26 +0200
commitdb79c15073c5b672fa7233fddfb44a61678e83bf (patch)
treea33fe7958411ecb8c6f875a5cec746c6d2074e91
parent93d5cea57e6cbbbf99066aef65da65795cf51fd6 (diff)
downloadpatches-db79c15073c5b672fa7233fddfb44a61678e83bf.tar
patches-db79c15073c5b672fa7233fddfb44a61678e83bf.tar.gz
gnu: mypaint-brushes: Update to 2.0.2.
* gnu/packages/gimp.scm (mypaint-brushes): Update to 2.0.2. [source, homepage]: Update upstream location. [arguments]: Remove it. [license]: Update license. (mypaint-brushes-1.3): New variable. (gimp)[inputs]: Use new variable.
-rw-r--r--gnu/packages/gimp.scm52
1 files changed, 30 insertions, 22 deletions
diff --git a/gnu/packages/gimp.scm b/gnu/packages/gimp.scm
index ab0dbcc925..d13390c214 100644
--- a/gnu/packages/gimp.scm
+++ b/gnu/packages/gimp.scm
@@ -183,7 +183,7 @@ buffers.")
("gexiv2" ,gexiv2)
("gtk+" ,gtk+-2)
("libmypaint" ,libmypaint)
- ("mypaint-brushes" ,mypaint-brushes)
+ ("mypaint-brushes" ,mypaint-brushes-1.3)
("exif" ,libexif) ; optional, EXIF + XMP support
("lcms" ,lcms) ; optional, color management
("librsvg" ,librsvg) ; optional, SVG support
@@ -298,34 +298,42 @@ brushstrokes which is used by MyPaint and GIMP.")
(define-public mypaint-brushes
(package
(name "mypaint-brushes")
- (version "1.3.0")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/Jehan/mypaint-brushes.git")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1iz89z6v2mp8j1lrf942k561s8311i3s34ap36wh4rybb2lq15m0"))))
+ (version "2.0.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mypaint/mypaint-brushes.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0kcqz13vzpy24dhmrx9hbs6s7hqb8y305vciznm15h277sabpmw9"))))
(build-system gnu-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'relax-dependency-version
- (lambda _
- (substitute* "autogen.sh"
- (("automake-1.13") "automake")
- (("aclocal-1.13") "aclocal"))
- #t)))))
(native-inputs
`(("autoconf" ,autoconf)
("automake" ,automake)))
(synopsis "Default brushes for MyPaint")
(description "This package provides the default set of brushes for
MyPaint.")
- (home-page "https://github.com/Jehan/mypaint-brushes")
- (license license:cc0)))
+ (home-page "https://github.com/mypaint/mypaint-brushes/")
+ ;; Scripts are distributed under GPL2+ terms, brushes are provided as
+ ;; public domain or under CC0 terms.
+ (license (list license:gpl2+ license:cc0 license:public-domain))))
+
+(define-public mypaint-brushes-1.3
+ (package
+ (inherit mypaint-brushes)
+ (name "mypaint-brushes")
+ (version "1.3.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mypaint/mypaint-brushes.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1c95l1vfz7sbrdlzrbz7h1p6s1k113kyjfd9wfnxlm0p6562cz3j"))))))
(define-public gimp-resynthesizer
;; GIMP does not respect any plugin search path environment variable, so after