summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorng0 <ng0@infotropique.org>2017-12-30 22:42:23 +0100
committerDanny Milosavljevic <dannym@scratchpost.org>2017-12-30 22:55:23 +0100
commitd58b0abd1464e129dd2a1e8f90a6fb47254c8dad (patch)
tree3f9fd11f8f0cee4a6e6ff417d1cb832d2a9c5915
parent1b332539ebfe258536ecdf1199fc82d7516fdad3 (diff)
downloadpatches-d58b0abd1464e129dd2a1e8f90a6fb47254c8dad.tar
patches-d58b0abd1464e129dd2a1e8f90a6fb47254c8dad.tar.gz
gnu: Add caja-extensions.
* gnu/packages/mate.scm (caja-extensions): New variable. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
-rw-r--r--gnu/packages/mate.scm58
1 files changed, 58 insertions, 0 deletions
diff --git a/gnu/packages/mate.scm b/gnu/packages/mate.scm
index 409ca570fe..1199b405ab 100644
--- a/gnu/packages/mate.scm
+++ b/gnu/packages/mate.scm
@@ -27,6 +27,7 @@
#:use-module (guix build-system glib-or-gtk)
#:use-module (guix build-system trivial)
#:use-module (gnu packages)
+ #:use-module (gnu packages attr)
#:use-module (gnu packages base)
#:use-module (gnu packages docbook)
#:use-module (gnu packages documentation)
@@ -39,8 +40,10 @@
#:use-module (gnu packages gnupg)
#:use-module (gnu packages gnuzilla)
#:use-module (gnu packages gtk)
+ #:use-module (gnu packages imagemagick)
#:use-module (gnu packages libcanberra)
#:use-module (gnu packages linux)
+ #:use-module (gnu packages messaging)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages photo)
#:use-module (gnu packages polkit)
@@ -662,6 +665,61 @@ icons on the MATE desktop. It works on local and remote filesystems.")
;; for us.
(license license:gpl2+)))
+(define-public caja-extensions
+ (package
+ (name "caja-extensions")
+ (version "1.18.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://pub.mate-desktop.org/releases/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0hgala7zkfsa60jflq3s4n9yd11dhfdcla40l83cmgc3r1az7cmw"))))
+ (build-system glib-or-gtk-build-system)
+ (arguments
+ `(#:configure-flags (list "--enable-sendto"
+ ;; TODO: package "gupnp" to enable 'upnp', package
+ ;; "gksu" to enable 'gksu'.
+ (string-append "--with-sendto-plugins=removable-devices,"
+ "caja-burn,emailclient,pidgin,gajim")
+ "--enable-image-converter"
+ "--enable-open-terminal" "--enable-share"
+ "--enable-wallpaper" "--enable-xattr-tags"
+ (string-append "--with-cajadir="
+ (assoc-ref %outputs "out")
+ "/lib/caja/extensions-2.0/"))))
+ (native-inputs
+ `(("intltool" ,intltool)
+ ("gettext" ,gettext-minimal)
+ ("glib:bin" ,glib "bin")
+ ("gobject-introspection" ,gobject-introspection)
+ ("gtk-doc" ,gtk-doc)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("attr" ,attr)
+ ("brasero" ,brasero)
+ ("caja" ,caja)
+ ("dbus" ,dbus)
+ ("dbus-glib" ,dbus-glib)
+ ("gajim" ,gajim) ;runtime only?
+ ("gtk+" ,gtk+)
+ ("imagemagick" ,imagemagick)
+ ("graphicsmagick" ,graphicsmagick)
+ ("mate-desktop" ,mate-desktop)
+ ("pidgin" ,pidgin) ;runtime only?
+ ("startup-notification" ,startup-notification)))
+ (home-page "https://mate-desktop.org/")
+ (synopsis "Extensions for the File manager Caja")
+ (description
+ "Caja is the official file manager for the MATE desktop.
+It allows for browsing directories, as well as previewing files and launching
+applications associated with them. Caja is also responsible for handling the
+icons on the MATE desktop. It works on local and remote filesystems.")
+ (license license:gpl2+)))
+
(define-public mate-control-center
(package
(name "mate-control-center")