summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-04-11 20:28:15 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-04-12 00:13:14 +0200
commit6c54d06ec122787c7e7439f22dea6bc9616ec831 (patch)
tree309fb57a2656e33888049d56f2c72ca886e2c520
parenta1da0fb20b99ba80bd58dd5b2ab08d61f3e8f9c8 (diff)
downloadpatches-6c54d06ec122787c7e7439f22dea6bc9616ec831.tar
patches-6c54d06ec122787c7e7439f22dea6bc9616ec831.tar.gz
gnu: ephemeralpg: Update to 3.0.
* gnu/packages/databases.scm (ephemeralpg): Update to 3.0. [arguments]: Set #:test-target and use the standard ‘check’ phase.
-rw-r--r--gnu/packages/databases.scm13
1 files changed, 6 insertions, 7 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index d180f347e0..a6f78154e8 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -225,7 +225,7 @@ standard Go idioms.")
(define-public ephemeralpg
(package
(name "ephemeralpg")
- (version "2.9")
+ (version "3.0")
(source
(origin
(method url-fetch)
@@ -233,17 +233,14 @@ standard Go idioms.")
"https://eradman.com/ephemeralpg/code/ephemeralpg-"
version ".tar.gz"))
(sha256
- (base32 "1ghp3kya4lxvfwz3c022cx9vqf55jbf9sjw60bxjcb5sszklyc89"))))
+ (base32 "1j0g7g114ma7y7sadbng5p1ss1zsm9zpicm77qspym6565733vvh"))))
(build-system gnu-build-system)
(arguments
'(#:make-flags (list "CC=gcc"
(string-append "PREFIX=" %output))
#:phases
(modify-phases %standard-phases
- (delete 'configure)
- (replace 'check
- (lambda* (#:key inputs #:allow-other-keys)
- (invoke "ruby" "test.rb")))
+ (delete 'configure) ; no configure script
(add-after 'install 'wrap
(lambda* (#:key inputs outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))
@@ -255,11 +252,13 @@ standard Go idioms.")
"/bin")
;; For getsocket.
,(string-append out "/bin")))))
- #t)))))
+ #t)))
+ #:test-target "test"))
(inputs
`(("postgresql" ,postgresql)
("util-linux" ,util-linux)))
(native-inputs
+ ;; For tests.
`(("ruby" ,ruby)
("which" ,which)))
(home-page "https://eradman.com/ephemeralpg/")