summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-04-12 08:55:10 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-04-12 08:59:29 +0300
commit1518b4bceb9955ed6d94432d651b7a2a9f3052e1 (patch)
treecf3fe6fa92a11612ab30a5ed7d0eb9a81cf25480
parentaec0ae27121d8004b7053def6a2b3fe71877e6ab (diff)
downloadpatches-1518b4bceb9955ed6d94432d651b7a2a9f3052e1.tar
patches-1518b4bceb9955ed6d94432d651b7a2a9f3052e1.tar.gz
gnu: Remove duplicate python-prometheus-client.
* gnu/packages/monitoring.scm (python-prometheus-client): Update to 0.7.1. * gnu/packages/python-xyz.scm (python-prometheus-client): Remove variable. * gnu/packages/monitoring.scm: Import (gnu packages monitoring).
-rw-r--r--gnu/packages/matrix.scm1
-rw-r--r--gnu/packages/monitoring.scm6
-rw-r--r--gnu/packages/python-xyz.scm22
3 files changed, 4 insertions, 25 deletions
diff --git a/gnu/packages/matrix.scm b/gnu/packages/matrix.scm
index 0aba774a91..7bbdc09688 100644
--- a/gnu/packages/matrix.scm
+++ b/gnu/packages/matrix.scm
@@ -20,6 +20,7 @@
#:use-module ((guix licenses) #:prefix license:)
#:use-module (gnu packages check)
#:use-module (gnu packages databases)
+ #:use-module (gnu packages monitoring)
#:use-module (gnu packages python-crypto)
#:use-module (gnu packages python-web)
#:use-module (gnu packages python-xyz)
diff --git a/gnu/packages/monitoring.scm b/gnu/packages/monitoring.scm
index bcb8df24d0..8da31d6a84 100644
--- a/gnu/packages/monitoring.scm
+++ b/gnu/packages/monitoring.scm
@@ -5,6 +5,7 @@
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Gábor Boskovits <boskovits@gmail.com>
;;; Copyright © 2018, 2019 Oleg Pykhalov <go.wigust@gmail.com>
+;;; Copyright © 2020 Alex ter Weele <alex.ter.weele@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -371,14 +372,13 @@ demand.")
(define-public python-prometheus-client
(package
(name "python-prometheus-client")
- (version "0.5.0")
+ (version "0.7.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "prometheus_client" version))
(sha256
- (base32
- "0g7rpv1pq2lab1nfqdx98z9d3bqwc400alg1j4ynrpjkrbsizhg8"))))
+ (base32 "1ni2yv4ixwz32nz39ckia76lvggi7m19y5f702w5qczbnfi29kbi"))))
(build-system python-build-system)
(arguments
'(;; No included tests.
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 2ecf7115ab..64b1e6d8dc 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -19236,28 +19236,6 @@ simple and fast to verify, and decouple authorization policy from the
enforcement of that policy.")
(license license:expat)))
-(define-public python-prometheus-client
- (package
- (name "python-prometheus-client")
- (version "0.7.1")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "prometheus_client" version))
- (sha256
- (base32 "1ni2yv4ixwz32nz39ckia76lvggi7m19y5f702w5qczbnfi29kbi"))))
- (build-system python-build-system)
- (arguments
- ;; TODO: No tests in the PyPI distribution.
- `(#:tests? #f))
- (propagated-inputs
- `(("python-twisted" ,python-twisted)))
- (home-page "https://github.com/prometheus/client_python")
- (synopsis "Prometheus instrumentation library")
- (description
- "This is the official Python client for the Prometheus monitoring server.")
- (license license:asl2.0)))
-
(define-public python-ldap3
(package
(name "python-ldap3")