summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2020-04-10 09:27:00 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2020-04-11 10:04:39 +0200
commit0493ead644196bb1c933719d4c0e63e665fd102d (patch)
tree20f5f64cddd1eeec9afbe1531db2068df9f09094
parent406130550912ee1254198b6349d7d7892e59217b (diff)
downloadpatches-0493ead644196bb1c933719d4c0e63e665fd102d.tar
patches-0493ead644196bb1c933719d4c0e63e665fd102d.tar.gz
gnu: Merge ham-radio and sdr modules into radio module.base-for-series-3495
* gnu/packages/ham-radio.scm: Rename to 'radio.scm'. * gnu/packages/sdr.scm: Remove file. (liquid-dsp): Move to ... * gnu/packages/radio.scm (liquid-dsp): ... here. * gnu/local.mk (GNU_SYSTEM_MODULES): Remove 'ham-radio.scm' and 'sdr.scm'. Add 'radio.scm'.
-rw-r--r--gnu/local.mk3
-rw-r--r--gnu/packages/radio.scm (renamed from gnu/packages/ham-radio.scm)34
-rw-r--r--gnu/packages/sdr.scm57
3 files changed, 33 insertions, 61 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index aba58ae03a..ac5fb0cfd1 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -256,7 +256,6 @@ GNU_SYSTEM_MODULES = \
%D%/packages/haskell-crypto.scm \
%D%/packages/haskell-web.scm \
%D%/packages/haskell-xyz.scm \
- %D%/packages/ham-radio.scm \
%D%/packages/hexedit.scm \
%D%/packages/hugs.scm \
%D%/packages/hurd.scm \
@@ -435,6 +434,7 @@ GNU_SYSTEM_MODULES = \
%D%/packages/toys.scm \
%D%/packages/tryton.scm \
%D%/packages/qt.scm \
+ %D%/packages/radio.scm \
%D%/packages/ragel.scm \
%D%/packages/rails.scm \
%D%/packages/ratpoison.scm \
@@ -463,7 +463,6 @@ GNU_SYSTEM_MODULES = \
%D%/packages/scsi.scm \
%D%/packages/sdcc.scm \
%D%/packages/sdl.scm \
- %D%/packages/sdr.scm \
%D%/packages/search.scm \
%D%/packages/security-token.scm \
%D%/packages/selinux.scm \
diff --git a/gnu/packages/ham-radio.scm b/gnu/packages/radio.scm
index 56a9719414..e1e5a98c68 100644
--- a/gnu/packages/ham-radio.scm
+++ b/gnu/packages/radio.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2017, 2018, 2019 Arun Isaac <arunisaac@systemreboot.net>
+;;; Copyright © 2019 Christopher Howard <christopher@librehacker.com>
;;; Copyright © 2019, 2020 Evan Straw <evan.straw99@gmail.com>
;;; Copyright © 2020 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2020 Danny Milosavljevic <dannym@scratchpost.org>
@@ -20,7 +21,7 @@
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
-(define-module (gnu packages ham-radio)
+(define-module (gnu packages radio)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix download)
@@ -50,7 +51,6 @@
#:use-module (gnu packages python-science)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages qt)
- #:use-module (gnu packages sdr)
#:use-module (gnu packages sphinx)
#:use-module (gnu packages swig)
#:use-module (gnu packages tex)
@@ -63,6 +63,36 @@
#:use-module (guix build-system python)
#:use-module (guix build-system qt))
+(define-public liquid-dsp
+ (package
+ (name "liquid-dsp")
+ (version "1.3.2")
+ (source
+ (origin (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jgaeddert/liquid-dsp.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1n6dbg13q8ga5qhg1yiszwly4jj0rxqr6f1xwm9waaly5z493xsd"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("autoconf" ,autoconf)))
+ (inputs
+ `(("fftw" ,fftw)
+ ("fftwf" ,fftwf)))
+ (home-page "https://liquidsdr.org")
+ (synopsis "Signal processing library for software-defined radios")
+ (description
+ "Liquid DSP is a @dfn{digital signal processing} (DSP) library designed
+specifically for software-defined radios on embedded platforms. The aim is to
+provide a lightweight DSP library that does not rely on a myriad of external
+dependencies or proprietary and otherwise cumbersome frameworks. All signal
+processing elements are designed to be flexible, scalable, and dynamic,
+including filters, filter design, oscillators, modems, synchronizers, complex
+mathematical operations, and much more.")
+ (license license:expat)))
+
(define-public rtl-sdr
(package
(name "rtl-sdr")
diff --git a/gnu/packages/sdr.scm b/gnu/packages/sdr.scm
deleted file mode 100644
index 563a9b3887..0000000000
--- a/gnu/packages/sdr.scm
+++ /dev/null
@@ -1,57 +0,0 @@
-;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2019 Christopher Howard <christopher@librehacker.com>
-;;; Copyright © 2019, 2020 Evan Straw <evan.straw99@gmail.com>
-;;;
-;;; This file is part of GNU Guix.
-;;;
-;;; GNU Guix is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; GNU Guix is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
-
-(define-module (gnu packages sdr)
- #:use-module ((guix licenses) #:prefix license:)
- #:use-module (guix packages)
- #:use-module (guix download)
- #:use-module (guix git-download)
- #:use-module (guix build-system gnu)
- #:use-module (gnu packages algebra)
- #:use-module (gnu packages autotools))
-
-(define-public liquid-dsp
- (package
- (name "liquid-dsp")
- (version "1.3.2")
- (source
- (origin (method git-fetch)
- (uri (git-reference
- (url "https://github.com/jgaeddert/liquid-dsp.git")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "1n6dbg13q8ga5qhg1yiszwly4jj0rxqr6f1xwm9waaly5z493xsd"))))
- (build-system gnu-build-system)
- (native-inputs
- `(("autoconf" ,autoconf)))
- (inputs
- `(("fftw" ,fftw)
- ("fftwf" ,fftwf)))
- (home-page "https://liquidsdr.org")
- (synopsis "Signal processing library for software-defined radios")
- (description
- "Liquid DSP is a @dfn{digital signal processing} (DSP) library designed
-specifically for software-defined radios on embedded platforms. The aim is to
-provide a lightweight DSP library that does not rely on a myriad of external
-dependencies or proprietary and otherwise cumbersome frameworks. All signal
-processing elements are designed to be flexible, scalable, and dynamic,
-including filters, filter design, oscillators, modems, synchronizers, complex
-mathematical operations, and much more.")
- (license license:expat)))