summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2016-06-07 07:58:51 -0400
committerDavid Thompson <dthompson2@worcester.edu>2016-06-11 21:21:16 -0400
commit9987c57c74bcea6bf0594951e44ec3b1ba5e6380 (patch)
tree29e6c6c7f738ab7acebb6eb5b4de91ff03f83a06
parent813f814a2997445ea656085dc1816cbb1a93c664 (diff)
downloadpatches-9987c57c74bcea6bf0594951e44ec3b1ba5e6380.tar
patches-9987c57c74bcea6bf0594951e44ec3b1ba5e6380.tar.gz
gnu: Add moka-icon-theme.
* gnu/packages/gnome.scm (moka-icon-theme): New variable.
-rw-r--r--gnu/packages/gnome.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index b63a602c90..365c93be12 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -5215,3 +5215,38 @@ like GNOME, Unity, Budgie, Pantheon, XFCE, Mate, etc.")
(home-page "https://github.com/horst3180/arc-theme")
;; No "or later" language found.
(license license:gpl3)))
+
+(define-public moka-icon-theme
+ (package
+ (name "moka-icon-theme")
+ (version "5.3.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/moka-project"
+ "/moka-icon-theme/archive/v"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1lnk7p8dsd9xh6cgz5krvlcr457w8yl4m6p6s5c2g5narsjswzrm"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-makefile.am
+ (lambda _
+ (substitute* '("Makefile.am")
+ (("\\$\\(DESTDIR\\)/usr/share")
+ "$(datadir)"))
+ #t))
+ (add-after 'patch-makefile.am 'bootstrap
+ (lambda _
+ (zero? (system* "autoreconf" "-vif")))))))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)))
+ (synopsis "Moka icon theme")
+ (description "Moka is a stylized desktop icon set, designed to be clear,
+simple and consistent.")
+ (home-page "http://snwh.org/moka")
+ (license license:gpl3+)))