summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-10-14 22:37:54 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-10-14 22:49:04 +0200
commit19e42618376e92cb9745197642ff5cb4afa39945 (patch)
tree2e9f75738ef5655d348a7a95fcee012983b695f8
parentdc505e3eb88faf3c952aa1de4a12a42111c3742c (diff)
downloadpatches-19e42618376e92cb9745197642ff5cb4afa39945.tar
patches-19e42618376e92cb9745197642ff5cb4afa39945.tar.gz
gnu: Add methyldackel.
* gnu/packages/bioinformatics.scm (methyldackel): New variable.
-rw-r--r--gnu/packages/bioinformatics.scm44
1 files changed, 44 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 12c30236cb..5f57a59b06 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -15304,3 +15304,47 @@ pairs.")
transcriptional derivatives and visualization of the resulting velocity
patterns.")
(license license:gpl3))))
+
+(define-public methyldackel
+ (package
+ (name "methyldackel")
+ (version "0.4.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/dpryan79/MethylDackel.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "10gh8k0ca92kywnrw5pkacq3g6r8s976s12k8jhp8g3g49q9a97g"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:test-target "test"
+ #:make-flags
+ (list "CC=gcc"
+ (string-append "prefix="
+ (assoc-ref %outputs "out") "/bin/"))
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'configure
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* "Makefile"
+ (("install MethylDackel \\$\\(prefix\\)" match)
+ (string-append "install -d $(prefix); " match)))
+ #t)))))
+ (inputs
+ `(("htslib" ,htslib)
+ ("zlib" ,zlib)))
+ ;; Needed for tests
+ (native-inputs
+ `(("python" ,python-wrapper)))
+ (home-page "https://github.com/dpryan79/MethylDackel")
+ (synopsis "Universal methylation extractor for BS-seq experiments")
+ (description
+ "MethylDackel will process a coordinate-sorted and indexed BAM or CRAM
+file containing some form of BS-seq alignments and extract per-base
+methylation metrics from them. MethylDackel requires an indexed fasta file
+containing the reference genome as well.")
+ ;; See https://github.com/dpryan79/MethylDackel/issues/85
+ (license license:expat)))