summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2016-12-29 09:20:08 +0100
committerRicardo Wurmus <rekado@elephly.net>2016-12-29 09:20:08 +0100
commite62e975b1fadfbe8b6e8fbf1766c86fffa88d8db (patch)
treef37269daca8769b7e898bf5f63e9d0716efc4031
parente7b9da2411df231a07709ec85918345189303af7 (diff)
downloadpatches-e62e975b1fadfbe8b6e8fbf1766c86fffa88d8db.tar
patches-e62e975b1fadfbe8b6e8fbf1766c86fffa88d8db.tar.gz
gnu: mu: Avoid bootstrapping.
* gnu/packages/mail.scm (mu)[arguments]: Rename "patch-configure.ac" to "patch-configure" and only patch "configure" script; remove "autoreconf" phase. [native-inputs]: Remove "autoconf", "automake", "libtool", and "texinfo".
-rw-r--r--gnu/packages/mail.scm15
1 files changed, 4 insertions, 11 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index c7fc9ead11..e359c8735a 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -393,11 +393,7 @@ repository and Maildir/IMAP as LOCAL repository.")
(native-inputs
`(("pkg-config" ,pkg-config)
("glib" ,glib "bin") ; for gtester
- ("autoconf" ,autoconf)
- ("automake" ,automake)
- ("emacs" ,emacs-minimal)
- ("libtool" ,libtool)
- ("texinfo" ,texinfo)))
+ ("emacs" ,emacs-minimal)))
;; TODO: Add webkit and gtk to build the mug GUI.
(inputs
`(("xapian" ,xapian)
@@ -413,18 +409,15 @@ repository and Maildir/IMAP as LOCAL repository.")
(guix build emacs-utils))
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'patch-configure.ac
+ (add-after 'unpack 'patch-configure
;; By default, elisp code goes to "share/emacs/site-lisp/mu4e",
;; so our Emacs package can't find it. Setting "--with-lispdir"
;; configure flag doesn't help because "mu4e" will be added to
;; the lispdir anyway, so we have to modify "configure.ac".
(lambda _
- (substitute* "configure.ac"
- (("^ +lispdir=.*") ""))
+ (substitute* "configure"
+ (("^ +lispdir=\"\\$\\{lispdir\\}/mu4e/\".*") ""))
#t))
- (add-after 'patch-configure.ac 'autoreconf
- (lambda _
- (zero? (system* "autoreconf" "-vi"))))
(add-before 'check 'check-tz-setup
(lambda* (#:key inputs #:allow-other-keys)
;; For mu/test/test-mu-query.c