summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2018-02-03 13:46:13 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2018-02-14 15:54:26 +0300
commitac07b94ab53fb13bb56ea876a5143985e6dfaf11 (patch)
tree45a1a6da6702d1daa63f147d059429ac66da79da
parent5fe9ba59ba1cea12a70d011aacbace52e3bfda18 (diff)
downloadpatches-ac07b94ab53fb13bb56ea876a5143985e6dfaf11.tar
patches-ac07b94ab53fb13bb56ea876a5143985e6dfaf11.tar.gz
gnu: Add emacs-scratch-el.
* gnu/packages/emacs.scm (emacs-scratch-el): New public variable.
-rw-r--r--gnu/packages/emacs.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index dd3a6acf42..4829941ebf 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -7058,3 +7058,41 @@ navigation with the grails mode.")
@code{org-tree-slide-mode} to enter the slideshow mode, and then @kbd{C->} and
@kbd{C-<} to jump to the next and previous slide.")
(license license:gpl3+))))
+
+(define-public emacs-scratch-el
+ (let ((commit "2cdf2b841ce7a0987093f65b0cc431947549f897")
+ (revision "1"))
+ (package
+ (name "emacs-scratch-el")
+ (version (git-version "1.2" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ieure/scratch-el.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0wscsndynjmnliajqaz28r1ww81j8wh84zwaaswx51abhwgl0idf"))))
+ (build-system emacs-build-system)
+ (native-inputs
+ `(("texinfo" ,texinfo)))
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'install-doc
+ (lambda* (#:key outputs #:allow-other-keys)
+ (unless (invoke "makeinfo" "scratch.texi")
+ (error "makeinfo failed"))
+ (install-file "scratch.info"
+ (string-append (assoc-ref outputs "out")
+ "/share/info"))
+ #t)))))
+ (home-page "https://github.com/ieure/scratch-el/")
+ (synopsis "Create scratch buffers with the same mode as current buffer")
+ (description "Scratch is an extension to Emacs that enables one to create
+scratch buffers that are in the same mode as the current buffer. This is
+notably useful when working on code in some language; you may grab code into a
+scratch buffer, and, by virtue of this extension, do so using the Emacs
+formatting rules for that language.")
+ (license license:bsd-2))))