summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorng0 <ng0@libertad.pw>2016-12-21 11:47:10 +0000
committerLeo Famulari <leo@famulari.name>2016-12-28 22:41:51 -0500
commita2c7d88e74b89b7370fc633fca76f9ba8095a6fc (patch)
tree39eb64dcda7a8fc5d3114b65fead1275663f980c
parenta7ad802be5f5e035d027558c3742aabacceef360 (diff)
downloadpatches-a2c7d88e74b89b7370fc633fca76f9ba8095a6fc.tar
patches-a2c7d88e74b89b7370fc633fca76f9ba8095a6fc.tar.gz
gnu: Add python-flask-multistatic.
* gnu/packages/python.scm (python-flask-multistatic, python2-flask-multistatic): New variables. Signed-off-by: Leo Famulari <leo@famulari.name>
-rw-r--r--gnu/packages/python.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index fcbb7928c6..b5a84d824a 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -9340,6 +9340,29 @@ upload, and reCAPTCHA.")
(define-public python2-flask-wtf
(package-with-python2 python-flask-wtf))
+(define-public python-flask-multistatic
+ (package
+ (name "python-flask-multistatic")
+ (version "1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "flask-multistatic" version))
+ (sha256
+ (base32
+ "0p4v50rwv64wcd0zlq7rzl4waprwr4hj19s3cgf1isywa7jcisgm"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-flask" ,python-flask)))
+ (home-page "https://pagure.io/flask-multistatic")
+ (synopsis "Flask plugin to allow overriding static files")
+ (description "@code{flask-multistatic} is a flask plugin that adds support
+for overriding static files.")
+ (license license:gpl3+)))
+
+(define-public python2-flask-multistatic
+ (package-with-python2 python-flask-multistatic))
+
(define-public python-cookies
(package
(name "python-cookies")