summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-06-29 01:45:09 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-06-29 01:54:34 +0200
commit6309636640f73c2211e58ab3816d564dc4d8e807 (patch)
tree2fcbcc5ba901619ba5670756b0c13ef4ba3dc442
parenta0aa6b59ddff7da63f6f628d93b0aadecae59acb (diff)
downloadpatches-6309636640f73c2211e58ab3816d564dc4d8e807.tar
patches-6309636640f73c2211e58ab3816d564dc4d8e807.tar.gz
gnu: emacs-ess: Use texlive-union instead of texlive.
* gnu/packages/emacs.scm (emacs-ess)[arguments]: Add phase "set-HOME". [native-inputs]: Replace texlive with a texlive-union.
-rw-r--r--gnu/packages/emacs.scm11
1 files changed, 9 insertions, 2 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index feff22a1b1..cfebe772f2 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -3084,14 +3084,21 @@ E-Prime forbids the use of the \"to be\" form to strengthen your writing.")
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "Makeconf"
(("SHELL = /bin/sh")
- (string-append "SHELL = " (which "sh")))))))))
+ (string-append "SHELL = " (which "sh"))))))
+ ;; FIXME: the texlive-union insists on regenerating fonts. It stores
+ ;; them in HOME, so it needs to be writeable.
+ (add-before 'build 'set-HOME
+ (lambda _ (setenv "HOME" "/tmp") #t)))))
(inputs
`(("emacs" ,emacs-minimal)
("r-minimal" ,r-minimal)))
(native-inputs
`(("perl" ,perl)
("texinfo" ,texinfo)
- ("texlive" ,texlive)))
+ ("texlive" ,(texlive-union (list texlive-latex-natbib
+ texlive-latex-seminar
+ texlive-latex-hyperref
+ texlive-tex-texinfo)))))
(home-page "http://ess.r-project.org/")
(synopsis "Emacs mode for statistical analysis programs")
(description "Emacs Speaks Statistics (ESS) is an add-on package for GNU