summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorng0 <ng0@libertad.pw>2016-12-21 11:47:12 +0000
committerLeo Famulari <leo@famulari.name>2016-12-28 22:41:51 -0500
commit460fccd4b3e6f2f595202747981046c7af103c59 (patch)
tree7d5263475841db855bc23b086ef1dd0f95862185
parent9f21414de4475a80722c827771af55ce7175fb19 (diff)
downloadpatches-460fccd4b3e6f2f595202747981046c7af103c59.tar
patches-460fccd4b3e6f2f595202747981046c7af103c59.tar.gz
gnu: Add python-munch.
* gnu/packages/python.scm (python-munch, python2-munch): New variables. Signed-off-by: Leo Famulari <leo@famulari.name>
-rw-r--r--gnu/packages/python.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index ea06d95dcd..a4ae51b92f 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -3347,6 +3347,27 @@ capabilities.")
(define python2-numpy-bootstrap
(package-with-python2 python-numpy-bootstrap))
+(define-public python-munch
+ (package
+ (name "python-munch")
+ (version "2.0.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "munch" version))
+ (sha256
+ (base32
+ "1cmqg91xnqx8gvnh4pmp0bfl1dfcm65d5p9mg73zz8pkjhx6h80l"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/Infinidat/munch")
+ (synopsis "Dot-accessible dictionary")
+ (description "Munch is a dot-accessible dictionary similar to JavaScript
+objects.")
+ (license license:expat)))
+
+(define-public python2-munch
+ (package-with-python2 python-munch))
+
(define-public python2-fastlmm
(package
(name "python2-fastlmm")