summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-04-10 23:11:44 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-04-10 23:27:17 +0200
commitfa8343de32833f2f819464128ee002d0ad64cb49 (patch)
tree5305c13dd5c54afe5f2e3f4e44caadbc1840ff7f
parent8e71625667f8a1dbb62b4e205a6c5ec51ef0c28f (diff)
downloadpatches-fa8343de32833f2f819464128ee002d0ad64cb49.tar
patches-fa8343de32833f2f819464128ee002d0ad64cb49.tar.gz
gnu: ephemeralpg: Update to 2.9.
* gnu/packages/databases.scm (ephemeralpg): Update to 2.9. [arguments]: Remove obsolete work-arounds. [native-inputs]: Add which.
-rw-r--r--gnu/packages/databases.scm24
1 files changed, 6 insertions, 18 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 7880d33216..d180f347e0 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -225,7 +225,7 @@ standard Go idioms.")
(define-public ephemeralpg
(package
(name "ephemeralpg")
- (version "2.8")
+ (version "2.9")
(source
(origin
(method url-fetch)
@@ -233,7 +233,7 @@ standard Go idioms.")
"https://eradman.com/ephemeralpg/code/ephemeralpg-"
version ".tar.gz"))
(sha256
- (base32 "1dpfxsd8a52psx3zlfbqkw53m35w28qwyb87a8anz143x6gnkkr4"))))
+ (base32 "1ghp3kya4lxvfwz3c022cx9vqf55jbf9sjw60bxjcb5sszklyc89"))))
(build-system gnu-build-system)
(arguments
'(#:make-flags (list "CC=gcc"
@@ -243,20 +243,7 @@ standard Go idioms.")
(delete 'configure)
(replace 'check
(lambda* (#:key inputs #:allow-other-keys)
- ;; The intention for one test is to test without PostgreSQL on
- ;; the $PATH, so replace the test $PATH with just the util-linux
- ;; bin, which contains getopt. It will hopefully be possible to
- ;; remove this for releases after 2.8.
- (substitute* "test.rb"
- (("/bin:/usr/bin")
- (string-append (assoc-ref inputs "util-linux")
- "/bin")))
- ;; Set the LC_ALL=C as some tests use sort, and the locale
- ;; affects the order. It will hopefully be possible to remove
- ;; this for releases after 2.8.
- (setenv "LC_ALL" "C")
- (invoke "ruby" "test.rb")
- #t))
+ (invoke "ruby" "test.rb")))
(add-after 'install 'wrap
(lambda* (#:key inputs outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))
@@ -266,14 +253,15 @@ standard Go idioms.")
"/bin")
,(string-append (assoc-ref inputs "postgresql")
"/bin")
- ;; For getsocket
+ ;; For getsocket.
,(string-append out "/bin")))))
#t)))))
(inputs
`(("postgresql" ,postgresql)
("util-linux" ,util-linux)))
(native-inputs
- `(("ruby" ,ruby)))
+ `(("ruby" ,ruby)
+ ("which" ,which)))
(home-page "https://eradman.com/ephemeralpg/")
(synopsis "Run temporary PostgreSQL databases")
(description