summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2020-04-09 22:56:27 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2020-04-09 23:12:33 +0200
commitf76ac21c16d8ba7b8717c4a3462f3c9a9b33ddea (patch)
treeb23ffa058f9ba67f02a0ba948d13f5f395f536c0
parent77dc12a8982a403139ea1e8add299683f6b68561 (diff)
downloadpatches-f76ac21c16d8ba7b8717c4a3462f3c9a9b33ddea.tar
patches-f76ac21c16d8ba7b8717c4a3462f3c9a9b33ddea.tar.gz
gnu: Add gqrx.
* gnu/packages/ham-radio.scm (gqrx): New variable. Co-authored-by: Danny Milosavljevic <dannym@scratchpost.org>
-rw-r--r--gnu/packages/ham-radio.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/ham-radio.scm b/gnu/packages/ham-radio.scm
index 66f17c7598..0758617176 100644
--- a/gnu/packages/ham-radio.scm
+++ b/gnu/packages/ham-radio.scm
@@ -423,3 +423,41 @@ to the fix block above.
@end itemize")
(home-page "https://git.osmocom.org/gr-iqbal/")
(license license:gpl3+)))
+
+(define-public gqrx
+ (package
+ (name "gqrx")
+ (version "2.12.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/csete/gqrx.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "00alf3q6y313xpx6p7v43vqsphd2x4am4q362lw21bcy9wc4jidw"))))
+ (build-system qt-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("alsa-lib" ,alsa-lib)
+ ("boost" ,boost)
+ ("fftwf" ,fftwf)
+ ("gmp" ,gmp)
+ ("gnuradio" ,gnuradio)
+ ("gnuradio-iqbalance" ,gnuradio-iqbalance)
+ ("gnuradio-osmosdr" ,gnuradio-osmosdr)
+ ("jack" ,jack-1)
+ ("log4cpp" ,log4cpp)
+ ("portaudio" ,portaudio)
+ ("pulseaudio" ,pulseaudio)
+ ("qtbase" ,qtbase)
+ ("qtsvg" ,qtsvg)))
+ (arguments
+ `(#:tests? #f)) ; No tests
+ (synopsis "Software defined radio receiver")
+ (description "Gqrx is a software defined radio (SDR) receiver implemented
+using GNU Radio and the Qt GUI toolkit.")
+ (home-page "https://gqrx.dk/")
+ (license license:gpl3+)))