summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-03-23 03:14:23 -0400
committerMark H Weaver <mhw@netris.org>2018-03-23 04:43:01 -0400
commite15793c8d05f6d6d734b8c163c384e84d4606d98 (patch)
tree81fe02647c669fbeb4180275afc354d4e3aeabf8
parentfeb0804376a116b90e559e30a36ccba2ed5f69f1 (diff)
downloadpatches-e15793c8d05f6d6d734b8c163c384e84d4606d98.tar
patches-e15793c8d05f6d6d734b8c163c384e84d4606d98.tar.gz
gnu: mozjs: Return #t from all phases.
* gnu/packages/gnuzilla.scm (mozjs)[arguments]: Return #t from the 'delete-timedout-test' phase. Use 'invoke' in the configure phase.
-rw-r--r--gnu/packages/gnuzilla.scm15
1 files changed, 8 insertions, 7 deletions
diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index 5a86c1196c..17a6719f86 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -98,7 +98,9 @@
(modify-phases %standard-phases
(add-after 'unpack 'delete-timedout-test
;; This test times out on slower hardware.
- (lambda _ (delete-file "js/src/jit-test/tests/basic/bug698584.js")))
+ (lambda _
+ (delete-file "js/src/jit-test/tests/basic/bug698584.js")
+ #t))
(add-before 'configure 'chdir
(lambda _
(chdir "js/src")
@@ -109,12 +111,11 @@
(let ((out (assoc-ref outputs "out")))
(setenv "SHELL" (which "sh"))
(setenv "CONFIG_SHELL" (which "sh"))
- (zero? (system*
- "./configure" (string-append "--prefix=" out)
- ,@(if (string=? "aarch64-linux"
- (%current-system))
- '("--host=aarch64-unknown-linux-gnu")
- '())))))))))
+ (invoke "./configure" (string-append "--prefix=" out)
+ ,@(if (string=? "aarch64-linux"
+ (%current-system))
+ '("--host=aarch64-unknown-linux-gnu")
+ '()))))))))
(home-page
"https://developer.mozilla.org/en-US/docs/Mozilla/Projects/SpiderMonkey")
(synopsis "Mozilla javascript engine")