summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2020-04-09 22:39:28 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2020-04-09 23:12:33 +0200
commitbc94b75d75b25f29a402130ef3131844bfc922dc (patch)
tree73a220d5fdc364b2a9e95d46c52b2eea76657817
parentaa862c2c87e236fb76e5fa48ac6c3bf9148f00ab (diff)
downloadpatches-bc94b75d75b25f29a402130ef3131844bfc922dc.tar
patches-bc94b75d75b25f29a402130ef3131844bfc922dc.tar.gz
gnu: Add libosmo-dsp.
* gnu/packages/ham-radio.scm (libosmo-dsp): New variable.
-rw-r--r--gnu/packages/ham-radio.scm46
1 files changed, 46 insertions, 0 deletions
diff --git a/gnu/packages/ham-radio.scm b/gnu/packages/ham-radio.scm
index 1948e97dad..33bff43b2a 100644
--- a/gnu/packages/ham-radio.scm
+++ b/gnu/packages/ham-radio.scm
@@ -29,6 +29,7 @@
#:use-module (gnu packages audio)
#:use-module (gnu packages autotools)
#:use-module (gnu packages base)
+ #:use-module (gnu packages bash)
#:use-module (gnu packages boost)
#:use-module (gnu packages check)
#:use-module (gnu packages documentation)
@@ -337,3 +338,48 @@ environment.")
to access different radio hardware.")
(home-page "https://osmocom.org/projects/gr-osmosdr/wiki/GrOsmoSDR")
(license license:gpl3+)))
+
+(define-public libosmo-dsp
+ (package
+ (name "libosmo-dsp")
+ (version "0.4.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.osmocom.org/libosmo-dsp")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "00plihnpym1gkfpflah8il9463qxzm9kx2f07jyvbkszpj8viq5g"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("bash-minimal" ,bash-minimal)
+ ("doxygen" ,doxygen)
+ ("git" ,git-minimal)
+ ("libtool" ,libtool)
+ ("pkg-config" ,pkg-config)
+ ("texlive" ,(texlive-union (list texlive-amsfonts
+ texlive-latex-amsmath
+ ;; TODO: Add newunicodechar.
+ texlive-latex-graphics)))))
+ (inputs
+ `(("fftwf" ,fftwf)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-paths
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "git-version-gen"
+ (("/bin/sh")
+ (string-append (assoc-ref inputs "bash")
+ "/bin/bash")))
+ #t)))))
+ (synopsis "DSP primitives for SDR")
+ (description
+ "This a C-language library for common DSP (Digital Signal Processing)
+primitives for SDR (Software Defined Radio).")
+ (home-page "https://osmocom.org/projects/libosmo-dsp")
+ (license license:gpl2+)))