summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2020-04-09 20:06:55 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2020-04-09 23:12:33 +0200
commitaa862c2c87e236fb76e5fa48ac6c3bf9148f00ab (patch)
tree6e4081b3c52e78b0de553331fc34949186004f1d
parentd042caf6b73a3547a6b6ef4a0b90601303e066e6 (diff)
downloadpatches-aa862c2c87e236fb76e5fa48ac6c3bf9148f00ab.tar
patches-aa862c2c87e236fb76e5fa48ac6c3bf9148f00ab.tar.gz
gnu: Add gnuradio-osmosdr.
* gnu/packages/ham-radio.scm (gnuradio-osmosdr): New variable.
-rw-r--r--gnu/packages/ham-radio.scm39
1 files changed, 38 insertions, 1 deletions
diff --git a/gnu/packages/ham-radio.scm b/gnu/packages/ham-radio.scm
index 15f15f5f02..1948e97dad 100644
--- a/gnu/packages/ham-radio.scm
+++ b/gnu/packages/ham-radio.scm
@@ -58,7 +58,8 @@
#:use-module (gnu packages xorg)
#:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
- #:use-module (guix build-system python))
+ #:use-module (guix build-system python)
+ #:use-module (guix build-system qt))
(define-public rtl-sdr
(package
@@ -300,3 +301,39 @@ create software-defined radios, or without hardware in a simulation-like
environment.")
(home-page "https://www.gnuradio.org")
(license license:gpl3+)))
+
+(define-public gnuradio-osmosdr
+ (package
+ (name "gnuradio-osmosdr")
+ (version "0.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.osmocom.org/gr-osmosdr")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1rdx7fa0xiq0qmgrrbby7z1bblmqhl9qh9jqpsznzxkx91f17ypd"))))
+ (build-system cmake-build-system)
+ (native-inputs
+ `(("doxygen" ,doxygen)
+ ("git" ,git-minimal)
+ ("pkg-config" ,pkg-config)
+ ("python" ,python)
+ ("python-mako" ,python-mako)
+ ("python-six" ,python-six)
+ ("swig" ,swig)))
+ (inputs
+ `(("boost" ,boost)
+ ("fftwf" ,fftwf)
+ ("gmp" ,gmp)
+ ("gnuradio" ,gnuradio)
+ ("log4cpp" ,log4cpp)
+ ;; TODO: Add more drivers.
+ ("rtl-sdr" ,rtl-sdr)))
+ (synopsis "GNU Radio block for interfacing with various radio hardware")
+ (description "This is a block for GNU Radio allowing to use a common API
+to access different radio hardware.")
+ (home-page "https://osmocom.org/projects/gr-osmosdr/wiki/GrOsmoSDR")
+ (license license:gpl3+)))