summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2020-04-09 22:49:33 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2020-04-09 23:12:33 +0200
commit77dc12a8982a403139ea1e8add299683f6b68561 (patch)
treec658ad52a4acd51500259badc1c2526db4d39468
parentbc94b75d75b25f29a402130ef3131844bfc922dc (diff)
downloadpatches-77dc12a8982a403139ea1e8add299683f6b68561.tar
patches-77dc12a8982a403139ea1e8add299683f6b68561.tar.gz
gnu: Add gnuradio-iqbalance.
* gnu/packages/ham-radio.scm (gnuradio-iqbalance): New variable.
-rw-r--r--gnu/packages/ham-radio.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/ham-radio.scm b/gnu/packages/ham-radio.scm
index 33bff43b2a..66f17c7598 100644
--- a/gnu/packages/ham-radio.scm
+++ b/gnu/packages/ham-radio.scm
@@ -383,3 +383,43 @@ to access different radio hardware.")
primitives for SDR (Software Defined Radio).")
(home-page "https://osmocom.org/projects/libosmo-dsp")
(license license:gpl2+)))
+
+(define-public gnuradio-iqbalance
+ (package
+ (name "gnuradio-iqbalance")
+ (version "0.38.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.osmocom.org/gr-iqbal")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0ksagwz05p3b0702q7ljq7013xmp0ijp30my9z6s3p7ja8dj42s3"))))
+ (build-system cmake-build-system)
+ (native-inputs
+ `(("doxygen" ,doxygen)
+ ("pkg-config" ,pkg-config)
+ ("python" ,python)
+ ("python-numpy" ,python-numpy)
+ ("python-six" ,python-six)
+ ("swig" ,swig)))
+ (inputs
+ `(("boost" ,boost)
+ ("fftwf" ,fftwf)
+ ("gmp" ,gmp)
+ ("gnuradio" ,gnuradio)
+ ("libosmo-dsp" ,libosmo-dsp)
+ ("log4cpp" ,log4cpp)))
+ (synopsis "GNU Radio block to correct IQ imbalance")
+ (description
+ "This is a GNU Radio block to correct IQ imbalance in quadrature
+receivers. It's composed of two main block:
+@itemize
+@item Fix: Given a phase and amplitude error, it will correct a complex signal.
+@item Optimize: Attempts to auto-detect the phase and amplitude error to feed
+to the fix block above.
+@end itemize")
+ (home-page "https://git.osmocom.org/gr-iqbal/")
+ (license license:gpl3+)))