summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuriithi Frederick Muriuki <fredmanglis@gmail.com>2017-03-26 12:23:34 +0300
committerLeo Famulari <leo@famulari.name>2017-03-28 15:59:22 -0400
commit5d0c3ba856e39be207debdf5091b4431dd726273 (patch)
tree5aa26a7e1f72185deaa37dfd462bb7f67a9a84c7
parent3061b33190b0e9b979255d70cbe3bc92a2e1e38d (diff)
downloadpatches-5d0c3ba856e39be207debdf5091b4431dd726273.tar
patches-5d0c3ba856e39be207debdf5091b4431dd726273.tar.gz
gnu: Add python-paramunittest
* gnu/packages/python.scm (python-paramunittest, python2-paramunittest): New variables. Signed-off-by: Leo Famulari <leo@famulari.name>
-rw-r--r--gnu/packages/python.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index ebb61f19b3..de459e5b31 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -13914,3 +13914,29 @@ possible to write plugins to add your own checks.")
,python2-backports-functools-lru-cache)
("python2-configparser" ,python2-configparser)
,@(package-propagated-inputs pylint))))))
+
+(define-public python-paramunittest
+ (package
+ (name "python-paramunittest")
+ (version "0.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "ParamUnittest" version))
+ (sha256
+ (base32
+ "0kp793hws5xv1wvycxq7jw2pwy36f35k39jg8hx5qikij5a0jid1"))))
+ (build-system python-build-system)
+ (home-page
+ "https://github.com/rik0/ParamUnittest")
+ (synopsis
+ "Simple extension to have parametrized unit tests")
+ (description
+ "This package allows to create parametrized unit-tests that work with the standard
+unittest package. A parametrized test case is automatically converted to multiple test
+cases. Since they are TestCase subclasses, they work with other test suites that
+recognize TestCases.")
+ (license license:bsd-2)))
+
+(define-public python2-python-paramunittest
+ (package-with-python2 python-paramunittest))