summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomZ <tomz@freedommail.ch>2020-04-07 20:48:45 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-04-10 18:43:38 +0200
commit3e6aa0ce968c79869a7a1dcfcfe682865d16ad45 (patch)
tree499028f21041c1fcaa785d398067ea1dae8f20b2
parentcf637690aa8c0301875ce0623e858eadb2d9996d (diff)
downloadpatches-3e6aa0ce968c79869a7a1dcfcfe682865d16ad45.tar
patches-3e6aa0ce968c79869a7a1dcfcfe682865d16ad45.tar.gz
gnu: Add fulcrum.
* gnu/packages/finance.scm (fulcrum): New variable.
-rw-r--r--gnu/packages/finance.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index ea1fcbe9d4..c639a9a562 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -17,6 +17,7 @@
;;; Copyright © 2019 Sebastian Schott <sschott@mailbox.org>
;;; Copyright © 2020 Kei Kebreau <kkebreau@posteo.net>
;;; Copyright © 2020 Christopher Lemmer Webber <cwebber@dustycloud.org>
+;;; Copyright © 2020 Tom Zander <tomz@freedommail.ch>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1401,6 +1402,44 @@ electronic cash system. This package provides a command line client and
a Qt GUI.")
(license license:expat)))
+(define-public fulcrum
+ (package
+ (name "fulcrum")
+ (version "1.0.5b")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://gitlab.com/FloweeTheHub/fulcrum/-/archive/v"
+ version "/fulcrum-v" version ".tar.gz"))
+ (sha256
+ (base32 "1c1hkik8avill8ha33g76rk4b03j5ac8wiml69q4jav7a63ywgfy"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ ;; Call qmake instead of configure to create a Makefile.
+ (replace 'configure
+ (lambda _
+ (invoke
+ "qmake"
+ (string-append "PREFIX=" %output)
+ "features="))))))
+ (native-inputs
+ `(("qttools" ,qttools)))
+ (inputs
+ `(("python" ,python)
+ ("qtbase" ,qtbase)
+ ("rocksdb" ,rocksdb)
+ ("zlib" ,zlib)))
+ (home-page "https://gitlab.com/FloweeTheHub/fulcrum/")
+ (synopsis "Fast and nimble SPV server for Bitcoin Cash")
+ (description
+ "Flowee Fulcrum is a server that is the back-end for @acronym{SPV,
+Simplified Payment Verification} wallets, it provides the full API for those
+walets in a fast and small server. The full data is stored in a full node,
+like Flowee the Hub, which Fulcrum connects to over RPC.")
+ (license license:gpl3+)))
+
(define-public beancount
(package
(name "beancount")