summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-08-28 17:22:28 +0200
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-08-31 17:01:33 +0200
commit2cb3ab482793e9b0dffd30b59d68a99aa169e0e2 (patch)
treed569b18f8d5233a23f6a333ec333aaf56af117a0
parent8b9bde077ad57b1ba8b4a09870d61f5642748b8a (diff)
downloadpatches-2cb3ab482793e9b0dffd30b59d68a99aa169e0e2.tar
patches-2cb3ab482793e9b0dffd30b59d68a99aa169e0e2.tar.gz
gnu: Add ruby-thor.
* gnu/packages/ruby.scm (ruby-thor): New variable.
-rw-r--r--gnu/packages/ruby.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 8170169bed..4d1061e5a9 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -482,6 +482,27 @@ Ruby.")
(home-page "https://github.com/maik/xml-simple")
(license license:ruby)))
+(define-public ruby-thor
+ (package
+ (name "ruby-thor")
+ (version "0.19.1")
+ (source (origin
+ (method url-fetch)
+ (uri (rubygems-uri "thor" version))
+ (sha256
+ (base32
+ "08p5gx18yrbnwc6xc0mxvsfaxzgy2y9i78xq7ds0qmdm67q39y4z"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:tests? #f)) ; no test suite
+ (native-inputs
+ `(("bundler" ,bundler)))
+ (synopsis "Ruby toolkit for building command-line interfaces")
+ (description "Thor is a toolkit for building powerful command-line
+interfaces.")
+ (home-page "http://whatisthor.com/")
+ (license license:expat)))
+
(define-public ruby-useragent
(package
(name "ruby-useragent")