summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2020-04-09 15:22:16 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2020-04-09 23:12:32 +0200
commit9ed66ad7092b0116368772f9d8aa3f1d70373235 (patch)
tree4eb97af4190979e9ff17adfaa0293447c7db8125
parent575a9b03aebbdc109540ef5c287f254f6fd9579c (diff)
downloadpatches-9ed66ad7092b0116368772f9d8aa3f1d70373235.tar
patches-9ed66ad7092b0116368772f9d8aa3f1d70373235.tar.gz
gnu: Add python-click-plugins.
* gnu/packages/python-xyz.scm (python-click-plugins): New variable.
-rw-r--r--gnu/packages/python-xyz.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index d7b9ebb500..4f6294ee73 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -19500,3 +19500,24 @@ an identity provider. The distribution contains examples of both.
This package was originally written to work in a WSGI environment, but
there are extensions that allow you to use it with other frameworks.")
(license license:asl2.0)))
+
+(define-public python-click-plugins
+ (package
+ (name "python-click-plugins")
+ (version "1.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "click-plugins" version))
+ (sha256
+ (base32 "0jr6bxj67vg988vkm6nz8jj98v9lg46bn49lkhak3n598jbrkas6"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-pytest" ,python-pytest)))
+ (propagated-inputs
+ `(("python-click" ,python-click)))
+ (synopsis "Extension for Click to register external CLI commands")
+ (description "This package provides n extension module for Click to
+register external CLI commands via setuptools entry-points.")
+ (home-page "https://github.com/click-contrib/click-plugins")
+ (license license:bsd-3)))