summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2020-04-09 16:03:03 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2020-04-09 23:12:33 +0200
commit7cd2609e3fcb94db28ac261d1dbcc6e4bc85f66f (patch)
tree07f57623e6e65b7fa7402a9ec6b3423e48268bc7
parent9ed66ad7092b0116368772f9d8aa3f1d70373235 (diff)
downloadpatches-7cd2609e3fcb94db28ac261d1dbcc6e4bc85f66f.tar
patches-7cd2609e3fcb94db28ac261d1dbcc6e4bc85f66f.tar.gz
gnu: Add codec2.
* gnu/packages/audio.scm (codec2): New variable.
-rw-r--r--gnu/packages/audio.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index e602b002f2..bf16e09f61 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -29,6 +29,7 @@
;;; Copyright © 2019 Hartmt Goebel <h.goebel@crazy-compilers.com>
;;; Copyright © 2019 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
+;;; Copyright © 2020 Guillaume Le Vaillant <glv@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -99,6 +100,7 @@
#:use-module (gnu packages telephony)
#:use-module (gnu packages linphone)
#:use-module (gnu packages tls)
+ #:use-module (gnu packages valgrind)
#:use-module (gnu packages video)
#:use-module (gnu packages vim) ;xxd
#:use-module (gnu packages webkit)
@@ -4206,3 +4208,37 @@ minimum.")
`(("librsvg" ,librsvg)
,@(package-inputs ztoolkit)))
(synopsis "ZToolkit with SVG support")))
+
+(define-public codec2
+ (package
+ (name "codec2")
+ (version "0.9.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/drowe67/codec2.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1jpvr7bra8srz8jvnlbmhf8andbaavq5v01qjnp2f61za93rzwba"))))
+ (build-system cmake-build-system)
+ (native-inputs
+ `(("bc" ,bc)
+ ("octave" ,octave)
+ ("valgrind" ,valgrind)))
+ (arguments
+ `(#:tests? #f ; TODO: Fix tests (paths, graphic toolkit, octave modules).
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'set-test-environment
+ (lambda _
+ (setenv "HOME" "/tmp")
+ #t)))))
+ (synopsis "Speech codec")
+ (description
+ "Codec 2 is a speech codec designed for communications quality speech
+between 700 and 3200 bit/s. The main application is low bandwidth HF/VHF
+digital radio.")
+ (home-page "https://www.rowetel.com/?page_id=452")
+ (license license:lgpl2.1)))