summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-04-09 14:05:14 +0200
committerMarius Bakke <mbakke@fastmail.com>2020-04-09 20:04:44 +0200
commit1ffd618eba4836da5e5eaf6edd394ee949512bd8 (patch)
tree3c60dca5e068d58f6e7a7bf3d48f977a113f8b16
parentebdec923e37ec998f459d5656a101d062962fbb9 (diff)
downloadpatches-1ffd618eba4836da5e5eaf6edd394ee949512bd8.tar
patches-1ffd618eba4836da5e5eaf6edd394ee949512bd8.tar.gz
gnu: python-serpent: Declare python2 variant.
* gnu/packages/python-xyz.scm (python-serpent)[properties]: New field. (python2-serpent): New public variable.
-rw-r--r--gnu/packages/python-xyz.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 209564890e..f2e75d59a2 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -981,8 +981,17 @@ to rebuild the original object tree.
Because only safe literals are encoded, it is safe to send serpent data to
other machines, such as over the network.")
+ (properties `((python2-variant . ,(delay python2-serpent))))
(license license:expat)))
+(define-public python2-serpent
+ (let ((base (package-with-python2 (strip-python2-variant python-serpent))))
+ (package
+ (inherit base)
+ (propagated-inputs
+ `(("python-enum34" ,python2-enum34)
+ ,@(package-propagated-inputs base))))))
+
(define-public python-setuptools
(package
(name "python-setuptools")