summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2016-10-12 17:12:44 +0200
committerRicardo Wurmus <rekado@elephly.net>2016-10-17 18:09:16 +0200
commit89984be46e7714bc1b29fe04035964dfef3dec7e (patch)
tree2994ee1835378e23a0eb17506f3ba4a208245be7
parentf90b2dbdb715b4eb255b32f7843b1e830a285bda (diff)
downloadpatches-89984be46e7714bc1b29fe04035964dfef3dec7e.tar
patches-89984be46e7714bc1b29fe04035964dfef3dec7e.tar.gz
gnu: Add r-rcas.
* gnu/packages/bioinformatics.scm (r-rcas): New variable.
-rw-r--r--gnu/packages/bioinformatics.scm47
1 files changed, 47 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 5fbfdf0b9b..49d8ca9d27 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -56,6 +56,7 @@
#:use-module (gnu packages gtk)
#:use-module (gnu packages glib)
#:use-module (gnu packages groff)
+ #:use-module (gnu packages haskell)
#:use-module (gnu packages image)
#:use-module (gnu packages imagemagick)
#:use-module (gnu packages java)
@@ -7137,6 +7138,52 @@ ranges and it computes reads profiles and coverage profiles. It also handles
paired-end data.")
(license license:gpl2+)))
+(define-public r-rcas
+ (package
+ (name "r-rcas")
+ (version "0.99.6")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/BIMSBbioinfo/RCAS/archive/v"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1ljgl2b4r6w2n0i9i04d9xaphajsvhfkjdj2i2z830nha4m3w8f0"))))
+ (build-system r-build-system)
+ (native-inputs
+ `(("r-knitr" ,r-knitr)
+ ("r-testthat" ,r-testthat)
+ ;; During vignette building knitr checks that "pandoc-citeproc"
+ ;; is in the PATH.
+ ("ghc-pandoc-citeproc" ,ghc-pandoc-citeproc)))
+ (propagated-inputs
+ `(("r-data-table" ,r-data-table)
+ ("r-biomart" ,r-biomart)
+ ("r-org-hs-eg-db" ,r-org-hs-eg-db)
+ ("r-org-ce-eg-db" ,r-org-ce-eg-db)
+ ("r-org-dm-eg-db" ,r-org-dm-eg-db)
+ ("r-org-mm-eg-db" ,r-org-mm-eg-db)
+ ("r-bsgenome-hsapiens-ucsc-hg19" ,r-bsgenome-hsapiens-ucsc-hg19)
+ ("r-bsgenome-mmusculus-ucsc-mm9" ,r-bsgenome-mmusculus-ucsc-mm9)
+ ("r-bsgenome-celegans-ucsc-ce10" ,r-bsgenome-celegans-ucsc-ce10)
+ ("r-bsgenome-dmelanogaster-ucsc-dm3" ,r-bsgenome-dmelanogaster-ucsc-dm3)
+ ("r-topgo" ,r-topgo)
+ ("r-dt" ,r-dt)
+ ("r-plotly" ,r-plotly)
+ ("r-motifrg" ,r-motifrg)
+ ("r-genomation" ,r-genomation)
+ ("r-genomicfeatures" ,r-genomicfeatures)
+ ("r-rtracklayer" ,r-rtracklayer)
+ ("r-rmarkdown" ,r-rmarkdown)))
+ (synopsis "RNA-centric annotation system")
+ (description
+ "RCAS aims to be a standalone RNA-centric annotation system that provides
+intuitive reports and publication-ready graphics. This package provides the R
+library implementing most of the pipeline's features.")
+ (home-page "https://github.com/BIMSBbioinfo/RCAS")
+ (license license:expat)))
+
(define-public emboss
(package
(name "emboss")