summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2016-10-12 17:12:45 +0200
committerRicardo Wurmus <rekado@elephly.net>2016-10-17 18:09:20 +0200
commit509372970408584d769d0152bdaececccba753e4 (patch)
tree761911669c0f43a557ac2b9eb5ecbf6641766215
parent89984be46e7714bc1b29fe04035964dfef3dec7e (diff)
downloadpatches-509372970408584d769d0152bdaececccba753e4.tar
patches-509372970408584d769d0152bdaececccba753e4.tar.gz
gnu: Add rcas-web.
* gnu/packages/bioinformatics.scm (rcas-web): New variable.
-rw-r--r--gnu/packages/bioinformatics.scm45
1 files changed, 45 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 49d8ca9d27..43faaa078f 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -56,6 +56,7 @@
#:use-module (gnu packages gtk)
#:use-module (gnu packages glib)
#:use-module (gnu packages groff)
+ #:use-module (gnu packages guile)
#:use-module (gnu packages haskell)
#:use-module (gnu packages image)
#:use-module (gnu packages imagemagick)
@@ -7184,6 +7185,50 @@ library implementing most of the pipeline's features.")
(home-page "https://github.com/BIMSBbioinfo/RCAS")
(license license:expat)))
+(define-public rcas-web
+ (package
+ (name "rcas-web")
+ (version "0.0.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/BIMSBbioinfo/rcas-web/"
+ "releases/download/v" version
+ "/rcas-web-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0d3my0g8i7js59n184zzzjdki7hgmhpi4rhfvk7i6jsw01ba04qq"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'wrap-executable
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (json (assoc-ref inputs "guile-json"))
+ (redis (assoc-ref inputs "guile-redis"))
+ (path (string-append
+ json "/share/guile/site/2.2:"
+ redis "/share/guile/site/2.2")))
+ (wrap-program (string-append out "/bin/rcas-web")
+ `("GUILE_LOAD_PATH" ":" = (,path))
+ `("GUILE_LOAD_COMPILED_PATH" ":" = (,path))
+ `("R_LIBS_SITE" ":" = (,(getenv "R_LIBS_SITE")))))
+ #t)))))
+ (inputs
+ `(("r" ,r)
+ ("r-rcas" ,r-rcas)
+ ("guile-next" ,guile-next)
+ ("guile-json" ,guile2.2-json)
+ ("guile-redis" ,guile2.2-redis)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (home-page "https://github.com/BIMSBbioinfo/rcas-web")
+ (synopsis "Web interface for RNA-centric annotation system (RCAS)")
+ (description "This package provides a simple web interface for the
+@dfn{RNA-centric annotation system} (RCAS).")
+ (license license:agpl3+)))
+
(define-public emboss
(package
(name "emboss")