summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Garlick <pgarlick@tourbillion-technology.com>2020-04-06 16:02:16 +0100
committerPaul Garlick <pgarlick@tourbillion-technology.com>2020-04-07 14:51:04 +0100
commitc3dbbd82f05ecf68f63adfd8afa67d911690c2fa (patch)
treeec244f1b3180229040ba5fcd175e31bb524f394e
parent6482c3e358edda7c9add6b3bff05cc9ee68c8896 (diff)
downloadpatches-c3dbbd82f05ecf68f63adfd8afa67d911690c2fa.tar
patches-c3dbbd82f05ecf68f63adfd8afa67d911690c2fa.tar.gz
gnu: Add perl-digest-crc.
* gnu/packages/perl.scm (perl-digest-crc): New variable.
-rw-r--r--gnu/packages/perl.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 6e71f71a4f..7732a2f1df 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -3324,6 +3324,27 @@ each stack frame.")
(description "Devel::Symdump provides access to the perl symbol table.")
(license (package-license perl))))
+(define-public perl-digest-crc
+ (package
+ (name "perl-digest-crc")
+ (version "0.22")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/O/OL/OLIMAUL/Digest-CRC-"
+ version ".2.tar.gz"))
+ (sha256
+ (base32
+ "1jvqcyrbi11cj3vlfc9sq2g6rv9caizyjkjqsksvmxn6zgvm0aqi"))))
+ (build-system perl-build-system)
+ (home-page "https://metacpan.org/release/Digest-CRC")
+ (synopsis "Generic CRC functions")
+ (description "The @code{Digest::CRC} module calculates CRC sums of
+all sorts. It contains wrapper functions with the correct parameters
+for CRC-CCITT, CRC-16 and CRC-32.")
+ (license public-domain)))
+
(define-public perl-digest-hmac
(package
(name "perl-digest-hmac")