summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2020-04-07 10:59:30 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-04-07 10:59:59 +0200
commit2d0cfa71abdbc153d7794c81cb6884f91f7226bf (patch)
tree13c73674049db45cc3430ca359c96cfecaebb7e3
parenta6986961de1172fb3611def42dfc3f0bed18ac5a (diff)
downloadpatches-2d0cfa71abdbc153d7794c81cb6884f91f7226bf.tar
patches-2d0cfa71abdbc153d7794c81cb6884f91f7226bf.tar.gz
gnu: Add emacs-ctrlf.
* gnu/packages/emacs-xyz.scm (emacs-ctrlf): New variable.
-rw-r--r--gnu/packages/emacs-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 1a28832fbe..a2cc47ba59 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -1513,6 +1513,29 @@ always indented. It reindents after every change, making it more reliable
than @code{electric-indent-mode}.")
(license license:gpl2+)))
+(define-public emacs-ctrlf
+ (package
+ (name "emacs-ctrlf")
+ (version "1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/raxod502/ctrlf.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "10gnhafas54zj3z9173h1g7b519ac4i26afclmw3w1pk6qyyb03z"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/raxod502/ctrlf/")
+ (synopsis "Single-buffer text search in Emacs")
+ (description "CTRLF (pronounced @emph{control F}) is an intuitive and
+efficient solution for single-buffer text search in Emacs, replacing packages
+such as Isearch, Swiper, and helm-swoop. It takes inspiration from the
+widely-adopted and battle-tested @samp{Ctrl+F} interfaces in programs such as
+web browsers, but follows the flow and keybindings of Isearch.")
+ (license license:expat)))
+
(define-public emacs-dhall-mode
;; There is no proper release. The base version is extracted from the
;; "Version" keyword in the main file.