summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-11-02 22:43:09 +0200
committerEfraim Flashner <efraim@flashner.co.il>2017-11-02 22:43:55 +0200
commit5146f22b3b1615ed9d10796a0b1fffdf617138ef (patch)
tree0f41d323fb8cd09d21ab4085c8978ee5f7bb55f1
parentdb9107b90a1a152dc17a1414dcf1ca2761887a2f (diff)
downloadpatches-5146f22b3b1615ed9d10796a0b1fffdf617138ef.tar
patches-5146f22b3b1615ed9d10796a0b1fffdf617138ef.tar.gz
gnu: rfkill: Mark as superseded by util-linux.
* gnu/packages/linux.scm (rfkill)[properties]: New field, superseded by util-linux. * gnu/system.scm (%base-packages): Remove rfkill.
-rw-r--r--gnu/packages/linux.scm4
-rw-r--r--gnu/system.scm2
2 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 2bd81901d7..01b0af24b3 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -2643,7 +2643,9 @@ Command Translation} (SAT) are also supported.")
which is used to enable and disable wireless networking devices, typically
WLAN, Bluetooth and mobile broadband.")
(license (license:non-copyleft "file://COPYING"
- "See COPYING in the distribution."))))
+ "See COPYING in the distribution."))
+ ;; rfkill is part of util-linux as of 2.31.
+ (properties `((superseded . ,util-linux)))))
(define-public acpi
(package
diff --git a/gnu/system.scm b/gnu/system.scm
index 5f562b48bb..2ccae364de 100644
--- a/gnu/system.scm
+++ b/gnu/system.scm
@@ -516,7 +516,7 @@ explicitly appear in OS."
;; wireless-tools is deprecated in favor of iw, but it's still what
;; many people are familiar with, so keep it around.
- iw wireless-tools rfkill
+ iw wireless-tools
iproute
net-tools ; XXX: remove when Inetutils suffices