summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2020-04-07 10:30:23 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-04-07 10:59:59 +0200
commit1c17e087c2bb83c4a830c5a77f356114f371b0aa (patch)
treee31259bc8148b3a67d970f969d407bd3d7b4c829
parent1d05da03ee6f62c1e8a9d2315de0f847c4eeca00 (diff)
downloadpatches-1c17e087c2bb83c4a830c5a77f356114f371b0aa.tar
patches-1c17e087c2bb83c4a830c5a77f356114f371b0aa.tar.gz
gnu: Add emacs-selectrum.
* gnu/packages/emacs-xyz.scm (emacs-selectrum): New variable.
-rw-r--r--gnu/packages/emacs-xyz.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 7b2cb001ca..b72e8a54cc 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -5375,6 +5375,32 @@ extensions for @code{ivy-mode} and @code{company-mode} that make use of the
library.")
(license license:gpl3+))))
+(define-public emacs-selectrum
+ (package
+ (name "emacs-selectrum")
+ (version "1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/raxod502/selectrum.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "105zl102dwbzvk50xh6b824nq6p24kxhky18ghdnk5yi5sv620lm"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/raxod502/selectrum/")
+ (synopsis "Incremental narrowing in Emacs")
+ (description "Selectrum is a solution for incremental narrowing in
+Emacs, replacing Helm, Ivy, and IDO. Its design philosophy is based
+on choosing the right abstractions and prioritizing consistency and
+predictability over special-cased improvements for particular cases.
+As such, Selectrum follows existing Emacs conventions where they exist
+and are reasonable, and it declines to implement features which have
+marginal benefit compared to the additional complexity of a new
+interface.")
+ (license license:expat)))
+
(define-public emacs-smartparens
(package
(name "emacs-smartparens")