summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Garlick <pgarlick@tourbillion-technology.com>2020-04-07 13:24:28 +0100
committerPaul Garlick <pgarlick@tourbillion-technology.com>2020-04-07 14:51:05 +0100
commit18b46c5637db81ab5720363d7b64c1ef50633081 (patch)
tree76036d135854743d106b390c171854ee3b599dd0
parentc3dbbd82f05ecf68f63adfd8afa67d911690c2fa (diff)
downloadpatches-18b46c5637db81ab5720363d7b64c1ef50633081.tar
patches-18b46c5637db81ab5720363d7b64c1ef50633081.tar.gz
gnu: Add perl-data-integer.
* gnu/packages/perl.scm (perl-data-integer): New variable.
-rw-r--r--gnu/packages/perl.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 7732a2f1df..aaf3f256ff 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -2087,6 +2087,33 @@ algorithms that use entropy. There are random number generators and
functions to shuffle arrays.")
(license perl-license)))
+(define-public perl-data-integer
+ (package
+ (name "perl-data-integer")
+ (version "0.006")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/Z/ZE/ZEFRAM/Data-Integer-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0m53zxhx9sn49yqh7azlpyy9m65g54v8cd2ha98y77337gg7xdv3"))))
+ (build-system perl-build-system)
+ (native-inputs
+ `(("perl-module-build" ,perl-module-build)
+ ("perl-test-pod" ,perl-test-pod)
+ ("perl-test-pod-coverage" ,perl-test-pod-coverage)))
+ (home-page "https://metacpan.org/release/Data-Integer")
+ (synopsis "Details of the native integer data type")
+ (description "This module is about the native integer numerical
+data type. A native integer is one of the types of datum that can
+appear in the numeric part of a Perl scalar. This module supplies
+constants describing the native integer type. Both signed and
+unsigned representations are handled.")
+ (license perl-license)))
+
(define-public perl-data-uniqid
(package
(name "perl-data-uniqid")