summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Leung <bkleung89@gmail.com>2019-06-24 00:12:57 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2019-06-25 08:54:39 +0200
commit07fb336dc213b8128c5eb49d78fb46119b5b85cb (patch)
tree9df3c91b3473003250e6dc2db09ca88f1bcdeb38
parentb2f263797a6897758a241ed55879068487d7ceb0 (diff)
downloadpatches-07fb336dc213b8128c5eb49d78fb46119b5b85cb.tar
patches-07fb336dc213b8128c5eb49d78fb46119b5b85cb.tar.gz
gnu: emacs-orgit: Update to 1.5.3.
* gnu/packages/emacs-xyz.scm (emacs-orgit): Update to 1.5.3.
-rw-r--r--gnu/packages/emacs-xyz.scm41
1 files changed, 20 insertions, 21 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index aa780f8e25..7e650204c3 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -14822,31 +14822,30 @@ recursively. The results are cached for speed.")
(license license:gpl3+)))
(define-public emacs-orgit
- (let ((commit "2456436a7e64d26bcf455b3890a586acaa3e7f93"))
- (package
- (name "emacs-orgit")
- (version (git-version "1.5.1" "2" commit))
- (home-page "https://github.com/magit/orgit")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url home-page)
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1i52dq2ynddb1irgigr5mdwfbfd3bvm1f29jnzd7nlc0nk186nvh"))))
- (build-system emacs-build-system)
- (propagated-inputs
- `(("emacs-dash" ,emacs-dash)
- ("emacs-magit" ,emacs-magit)))
- (synopsis "Support for Org links to Magit buffers")
- (description "This package defines several Org link types, which can be
+ (package
+ (name "emacs-orgit")
+ (version "1.5.3")
+ (home-page "https://github.com/magit/orgit")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1ywavzki510rslsgfm0cnn3mlh644p61ha2nfb715xhkg7cd3j9g"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-dash" ,emacs-dash)
+ ("emacs-magit" ,emacs-magit)))
+ (synopsis "Support for Org links to Magit buffers")
+ (description "This package defines several Org link types, which can be
used to link to certain Magit buffers. Use the command
@command{org-store-link} while such a buffer is current to store a link.
Later you can insert it into an Org buffer using the command
@code{org-insert-link}.")
- (license license:gpl3+))))
+ (license license:gpl3+)))
(define-public emacs-amx
(package