summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaghav Gururajan <raghavgururajan@disroot.org>2020-04-01 23:04:34 -0400
committerDanny Milosavljevic <dannym@scratchpost.org>2020-04-06 01:05:43 +0200
commitfe8f1c0b194de2fa7aa5265a4a0424e82bd11af1 (patch)
tree5372186fbeddd5441bef2059102fe23342799613
parentf689d3d7d9ba3fa25b4839bdd1e4b98905f4869c (diff)
downloadpatches-fe8f1c0b194de2fa7aa5265a4a0424e82bd11af1.tar
patches-fe8f1c0b194de2fa7aa5265a4a0424e82bd11af1.tar.gz
gnu: Add mswebrtc.
* gnu/packages/linphone.scm (mswebrtc): New variable. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
-rw-r--r--gnu/packages/linphone.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/linphone.scm b/gnu/packages/linphone.scm
index 75c3476675..68a4e3e140 100644
--- a/gnu/packages/linphone.scm
+++ b/gnu/packages/linphone.scm
@@ -504,3 +504,31 @@ mediastreamer2 based on the openh264 library.")
AMR codec. It is based on the Skype's SILK implementation.")
(home-page "https://gitlab.linphone.org/BC/public/mssilk")
(license license:gpl2+)))
+
+(define-public mswebrtc
+ (package
+ (name "mswebrtc")
+ (version "1.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append "https://www.linphone.org/releases/sources/plugins/"
+ name "/" name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1wj28hl9myhshqmn64xg0jf07aw75gmnilb5rff6rcbdxim87mqr"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f ; No test target
+ #:configure-flags
+ (list
+ "-DENABLE_STATIC=NO")))
+ (inputs
+ `(("bctoolbox" ,bctoolbox)
+ ("mediastreamer2" ,mediastreamer2)
+ ("ortp" ,ortp)))
+ (synopsis "Media Streamer WebRTC Codec")
+ (description "MSWebRTC is a plugin of MediaStreamer, adding support for
+WebRTC codec. It includes features from WebRTC, such as, iSAC and AECM.")
+ (home-page "https://gitlab.linphone.org/BC/public/mswebrtc")
+ (license license:gpl2+)))