summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaghav Gururajan <raghavgururajan@disroot.org>2020-04-01 22:58:32 -0400
committerDanny Milosavljevic <dannym@scratchpost.org>2020-04-06 01:05:43 +0200
commitf689d3d7d9ba3fa25b4839bdd1e4b98905f4869c (patch)
treeaafbbccd6ab8406866dc074461d4f0fa92922a21
parent14e73f8f18f0140745f699ad622c1d9a3319dc51 (diff)
downloadpatches-f689d3d7d9ba3fa25b4839bdd1e4b98905f4869c.tar
patches-f689d3d7d9ba3fa25b4839bdd1e4b98905f4869c.tar.gz
gnu: Add mssilk.
* gnu/packages/linphone.scm (mssilk): New variable. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
-rw-r--r--gnu/packages/linphone.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/linphone.scm b/gnu/packages/linphone.scm
index 1dbf760a7a..75c3476675 100644
--- a/gnu/packages/linphone.scm
+++ b/gnu/packages/linphone.scm
@@ -477,3 +477,30 @@ and video calls or instant messaging capabilities to an application.")
mediastreamer2 based on the openh264 library.")
(home-page "https://gitlab.linphone.org/BC/public/msopenh264")
(license license:gpl2+)))
+
+(define-public mssilk
+ (package
+ (name "mssilk")
+ (version "1.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append "https://www.linphone.org/releases/sources/plugins/"
+ name "/" name "-" version ".tar.gz"))
+ (sha256
+ (base32 "07ip0vd29d1n98lnqs5wpimcsmpm65yl7g5vk4hbqghcbsjw94lj"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f ; No test target
+ #:configure-flags
+ (list
+ "-DENABLE_STATIC=NO"))) ; Not required
+ (inputs
+ `(("mediastreamer2" ,mediastreamer2)
+ ("ortp" ,ortp)))
+ (synopsis "Media Streamer SILK Codec")
+ (description "MSSILK is a plugin of MediaStreamer, adding support for
+AMR codec. It is based on the Skype's SILK implementation.")
+ (home-page "https://gitlab.linphone.org/BC/public/mssilk")
+ (license license:gpl2+)))