summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFederico Beffa <beffa@fbengineering.ch>2014-11-22 16:42:41 +0100
committerFederico Beffa <beffa@fbengineering.ch>2014-11-23 15:37:29 +0100
commitaf89a6673522a0260f04ae503b53813c053ca26f (patch)
tree1591f708188015a520b1114132fc105e0dc6e3a2
parentbc9812f15015400439e0142fdcfeead942c73050 (diff)
downloadpatches-af89a6673522a0260f04ae503b53813c053ca26f.tar
patches-af89a6673522a0260f04ae503b53813c053ca26f.tar.gz
gnu: atlas: Try to fix build on MIPS.
* gnu/packages/maths.scm (atlas): Add MIPS specific configure flags.
-rw-r--r--gnu/packages/maths.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 1aa3757ebe..cc068b98c7 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -979,6 +979,12 @@ point numbers")
;; Disable parallel build as it gives errors: atlas_pthread.h is
;; needed to compile C files before it is generated.
"-Ss" "pmake" "make -j 1"
+ ;; Probe is failing for MIPS. We therefore define the system
+ ;; architecture explicitly by setting (-A) MACHINETYPE = 49
+ ;; 'MIPSR1xK' and (-V) ISA = 1 'none'.
+ ,,@(if (string-prefix? "mips" (%current-system))
+ (list "-A" "49" "-V" "1")
+ (list))
;; Generate shared libraries.
"--shared"
;; Build a full LAPACK library.