summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-04-04 19:12:30 +0200
committerRicardo Wurmus <rekado@elephly.net>2020-04-06 08:40:50 +0200
commita71d335832ba390a572c8b71eb685816e8e2ab1f (patch)
treeaef89518560afd4fcad1833be60b515700f113cb
parent1d2e270e3eb2d0cf77bd9691bd5f64da8d6e8604 (diff)
downloadpatches-a71d335832ba390a572c8b71eb685816e8e2ab1f.tar
patches-a71d335832ba390a572c8b71eb685816e8e2ab1f.tar.gz
gnu: guile-for-guile-emacs: Update to 2.1.2-1.15ca784.
* gnu/packages/guile.scm (guile-for-guile-emacs): Update to 2.1.2-1.15ca784. [source]: Fetch from Guile upstream repository. [arguments]: Enable tests; replace 'bootstrap phase; disable only broken tests. [native-search-paths]: Inherit from guile-2.2.
-rw-r--r--gnu/packages/guile.scm80
1 files changed, 45 insertions, 35 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 9c707d4cde..c643f9d286 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -6,7 +6,7 @@
;;; Copyright © 2015, 2017 Christopher Allan Webber <cwebber@dustycloud.org>
;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2016, 2017 Leo Famulari <leo@famulari.name>
-;;; Copyright © 2016, 2019 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2016, 2019, 2020 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2017 Andy Wingo <wingo@igalia.com>
;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2017, 2019 Mathieu Othacehe <m.othacehe@gmail.com>
@@ -393,40 +393,50 @@ GNU@tie{}Guile. Use the @code{(ice-9 readline)} module and call its
(guile-variant-package-name "guile3.0")))
(define-public guile-for-guile-emacs
- (package (inherit guile-2.2)
- (name "guile-for-guile-emacs")
- (version "20150510.d8d9a8d")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "git://git.hcoop.net/git/bpt/guile.git")
- (commit "d8d9a8da05ec876acba81a559798eb5eeceb5a17")))
- (file-name (string-append name "-" version "-checkout"))
- (sha256
- (base32
- "00sprsshy16y8pxjy126hr2adqcvvzzz96hjyjwgg8swva1qh6b0"))))
- (arguments
- `(;; Tests aren't passing for now.
- ;; Obviously we should re-enable this!
- #:tests? #f
- ,@(package-arguments guile-2.2)))
- (native-inputs
- `(("autoconf" ,autoconf)
- ("automake" ,automake)
- ("libtool" ,libtool)
- ("flex" ,flex)
- ("texinfo" ,texinfo)
- ("gettext" ,gettext-minimal)
- ,@(package-native-inputs guile-2.2)))
- ;; Same as in guile-2.0
- (native-search-paths
- (list (search-path-specification
- (variable "GUILE_LOAD_PATH")
- (files '("share/guile/site/2.0")))
- (search-path-specification
- (variable "GUILE_LOAD_COMPILED_PATH")
- (files '("lib/guile/2.0/site-ccache"
- "share/guile/site/2.0")))))))
+ (let ((commit "15ca78482ac0dd2e3eb36dcb31765d8652d7106d")
+ (revision "1"))
+ (package (inherit guile-2.2)
+ (name "guile-for-guile-emacs")
+ (version (git-version "2.1.2" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "git://git.savannah.gnu.org/guile.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1l7ik4q4zk7vq4m3gnwizc0b64b1mdr31hxqlzxs94xaf2lvi7s2"))))
+ (arguments
+ (substitute-keyword-arguments (package-arguments guile-2.2)
+ ((#:phases phases '%standard-phases)
+ `(modify-phases ,phases
+ (replace 'bootstrap
+ (lambda _
+ ;; Disable broken tests.
+ ;; TODO: Fix them!
+ (substitute* "test-suite/tests/gc.test"
+ (("\\(pass-if \"after-gc-hook gets called\"" m)
+ (string-append "#;" m)))
+ (substitute* "test-suite/tests/version.test"
+ (("\\(pass-if \"version reporting works\"" m)
+ (string-append "#;" m)))
+ ;; Warning: Unwind-only `out-of-memory' exception; skipping pre-unwind handler.
+ ;; FAIL: test-out-of-memory
+ (substitute* "test-suite/standalone/Makefile.am"
+ (("(check_SCRIPTS|TESTS) \\+= test-out-of-memory") ""))
+
+ (patch-shebang "build-aux/git-version-gen")
+ (invoke "sh" "autogen.sh")
+ #t))))))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)
+ ("flex" ,flex)
+ ("texinfo" ,texinfo)
+ ("gettext" ,gettext-minimal)
+ ,@(package-native-inputs guile-2.2))))))
;;;