summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoseph LaFreniere <joseph@lafreniere.xyz>2020-04-05 10:19:28 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-04-05 10:19:28 +0200
commita24744bd0a9860c5233483e91c8ddb430311f9b7 (patch)
tree0f9885da3dc8bfc98387463d1f36353904c4c625
parentfb0aa4eb6c9de84809b9c0915029aa1c14b61ac5 (diff)
downloadpatches-a24744bd0a9860c5233483e91c8ddb430311f9b7.tar
patches-a24744bd0a9860c5233483e91c8ddb430311f9b7.tar.gz
gnu: Add emacs-form-feed.
* gnu/packages/emacs-xyz.scm (emacs-form-feed): New variable.
-rw-r--r--gnu/packages/emacs-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index cd2562103c..435bc7c417 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -1873,6 +1873,29 @@ environment set through Direnv.")
that the binary uses instead of the actual binary contents.")
(license license:gpl3+)))
+(define-public emacs-form-feed
+ (package
+ (name "emacs-form-feed")
+ (version "0.2.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/wasamasa/form-feed.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "171jna631b2iqcimfsik9c66gii8nc0zdb58m077w00rn7rcxbh2"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/wasamasa/form-feed")
+ (synopsis "Display ^L glyphs as horizontal lines")
+ (description
+ "This package provides a minor mode @code{form-feed-mode} to display page
+delimiters which usually appear as ^L glyphs on a single line as horizontal
+lines spanning the entire window. The minor mode is suitable for inclusion
+into mode hooks and is intended to be used that way.")
+ (license license:gpl3+)))
+
(define-public emacs-ggtags
(package
(name "emacs-ggtags")